p PatchFirst

PatchFirst · Latest vulnerabilities

dpkg vulnerabilities

Vulnerabilities published for dpkg in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2015-0860

    Not ratedEPSS 4.99%Fix available

    CVE-2015-0860

    Off-by-one error in the extracthalf function in dpkg-deb/extract.c in the dpkg-deb component in Debian dpkg 1.16.x before 1.16.17 and 1.17.x before 1.17.26 allows remote attackers to execute arbitrary code via the archive magic version number in an "old-style" Debian binary package, which triggers a stack-based buffer overflow.

    • Update to 1.17.5ubuntu5.5
    Published Updated
  2. CVE-2014-3865

    Not ratedEPSS 7.32%Public exploitFix available

    CVE-2014-3865

    Multiple directory traversal vulnerabilities in dpkg-source in dpkg-dev 1.3.0 allow remote attackers to modify files outside of the intended directories via a source package with a crafted Index: pseudo-header in conjunction with (1) missing --- and +++ header lines or (2) a +++ header line with a blank pathname.

    • Update to 1.17.5ubuntu5.3
    Published Updated
  3. CVE-2014-3127

    Not ratedEPSS 2.07%Fix available

    CVE-2014-3127

    dpkg 1.15.9 on Debian squeeze introduces support for the "C-style encoded filenames" feature without recognizing that the squeeze patch program lacks this feature, which triggers an interaction error that allows remote attackers to conduct directory traversal attacks and modify files outside of the intended directories via a crafted source package. NOTE: this can be considered a release engineering problem in the effort to fix CVE-2014-0471.

    • Update to 1.17.5ubuntu5.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →