p PatchFirst

PatchFirst · Latest vulnerabilities

nova vulnerabilities

Vulnerabilities published for nova in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 11

  1. CVE-2015-5162

    High · CVSS 7.5EPSS 3.09%Fix available

    CVE-2015-5162

    The image parser in OpenStack Cinder 7.0.2 and 8.0.0 through 8.1.1; Glance before 11.0.1 and 12.0.0; and Nova before 12.0.4 and 13.0.0 does not properly limit qemu-img calls, which might allow attackers to cause a denial of service (memory and disk consumption) via a crafted disk image.

    • Update to 1:2014.1.5-0ubuntu1.7
    Published Updated
  2. CVE-2016-2140

    Medium · CVSS 5.3EPSS 2.11%Fix available

    CVE-2016-2140

    The libvirt driver in OpenStack Compute (Nova) before 2015.1.4 (kilo) and 12.0.x before 12.0.3 (liberty), when using raw storage and use_cow_images is set to false, allows remote authenticated users to read arbitrary files via a crafted qcow2 header in an ephemeral or root disk.

    • Update to 1:2014.1.5-0ubuntu1.7
    Published Updated
  3. CVE-2015-8749

    Medium · CVSS 5.9EPSS 2.24%Public exploitFix available

    CVE-2015-8749

    The volume_utils._parse_volume_info function in OpenStack Compute (Nova) before 2015.1.3 (kilo) and 12.0.x before 12.0.1 (liberty) includes the connection_info dictionary in the StorageError message when using the Xen backend, which might allow attackers to obtain sensitive password information by reading log files or other unspecified vectors.

    • Update to 1:2014.1.5-0ubuntu1.7
    Published Updated
  4. CVE-2015-7548

    Low · CVSS 3.5EPSS 1.8%Fix available

    CVE-2015-7548

    OpenStack Compute (Nova) before 2015.1.3 (kilo) and 12.0.x before 12.0.1 (liberty), when using libvirt to spawn instances and use_cow_images is set to false, allow remote authenticated users to read arbitrary files by overwriting an instance disk with a crafted image and requesting a snapshot.

    • Update to 1:2014.1.5-0ubuntu1.7
    Published Updated
  5. CVE-2015-3280

    Not ratedEPSS 3.38%Fix available

    CVE-2015-3280

    OpenStack Compute (nova) before 2014.2.4 (juno) and 2015.1.x before 2015.1.2 (kilo) does not properly delete instances from compute nodes, which allows remote authenticated users to cause a denial of service (disk consumption) by deleting instances while in the resize state.

    • Update to 1:2014.1.5-0ubuntu1.7
    Published Updated
  6. CVE-2015-3241

    Not ratedEPSS 3.48%Fix available

    CVE-2015-3241

    OpenStack Compute (nova) 2015.1 through 2015.1.1, 2014.2.3, and earlier does not stop the migration process when the instance is deleted, which allows remote authenticated users to cause a denial of service (disk, network, and other resource consumption) by resizing and then deleting an instance.

    • Update to 1:2014.1.5-0ubuntu1.7
    Published Updated
  7. CVE-2014-3608

    Not ratedEPSS 1.73%Fix available

    CVE-2014-3608

    The VMWare driver in OpenStack Compute (Nova) before 2014.1.3 allows remote authenticated users to bypass the quota limit and cause a denial of service (resource consumption) by putting the VM into the rescue state, suspending it, which puts into an ERROR state, and then deleting the image. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-2573.

    • Update to 1:2014.1.3-0ubuntu1.1
    Published Updated
  8. CVE-2014-3517

    Not ratedEPSS 1.95%Fix available

    CVE-2014-3517

    api/metadata/handler.py in OpenStack Compute (Nova) before 2013.2.4, 2014.x before 2014.1.2, and Juno before Juno-2, when proxying metadata requests through Neutron, makes it easier for remote attackers to guess instance ID signatures via a brute-force attack that relies on timing differences in responses to instance metadata requests.

    • Update to 1:2014.1.2-0ubuntu1.1
    Published Updated
  9. CVE-2013-1068

    Not ratedEPSS 1.19%Fix available

    CVE-2013-1068

    The OpenStack Nova (python-nova) package 1:2013.2.3-0 before 1:2013.2.3-0ubuntu1.2 and 1:2014.1-0 before 1:2014.1-0ubuntu1.2 and Openstack Cinder (python-cinder) package 1:2013.2.3-0 before 1:2013.2.3-0ubuntu1.1 and 1:2014.1-0 before 1:2014.1-0ubuntu1.1 for Ubuntu 13.10 and 14.04 LTS does not properly set the sudo configuration, which makes it easier for attackers to gain privileges by leveraging another vulnerability.

    • Update to 1:2014.1-0ubuntu1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →