p PatchFirst

PatchFirst · Latest vulnerabilities

ppp vulnerabilities

Vulnerabilities published for ppp in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2018-11574

    Critical · CVSS 9.8EPSS 1.87%Fix available

    CVE-2018-11574

    Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the `refuse-app` option are unaffected.

    • Update to 2.4.5-5.1ubuntu2.3
    Published Updated
  2. CVE-2015-3310

    Not ratedEPSS 5.41%Fix available

    CVE-2015-3310

    Buffer overflow in the rc_mksid function in plugins/radius/util.c in Paul's PPP Package (ppp) 2.4.6 and earlier, when the PID for pppd is greater than 65535, allows remote attackers to cause a denial of service (crash) via a start accounting message to the RADIUS server.

    • Update to 2.4.5-5.1ubuntu2.2
    Published Updated
  3. CVE-2014-3158

    Not ratedEPSS 3.55%Fix available

    CVE-2014-3158

    Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

    • Update to 2.4.5-5.1ubuntu2.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →