p PatchFirst

PatchFirst · Latest vulnerabilities

tiff vulnerabilities · Page 5

Vulnerabilities published for tiff in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 111

  1. CVE-2016-9535

    Critical · CVSS 9.8EPSS 4.73%Fix available

    CVE-2016-9535

    tif_predict.h and tif_predict.c in libtiff 4.0.6 have assertions that can lead to assertion failures in debug mode, or buffer overflows in release mode, when dealing with unusual tile size like YCbCr with subsampling. Reported as MSVR 35105, aka "Predictor heap-buffer-overflow."

    • Update to 4.0.3-7ubuntu0.6
    Published Updated
  2. CVE-2016-8331

    High · CVSS 8.1EPSS 6.59%Fix available

    CVE-2016-8331

    An exploitable remote code execution vulnerability exists in the handling of TIFF images in LibTIFF version 4.0.6. A crafted TIFF document can lead to a type confusion vulnerability resulting in remote code execution. This vulnerability can be triggered via a TIFF file delivered to the application using LibTIFF's tag extension functionality.

    • Update to 4.0.3-7ubuntu0.6
    Published Updated
  3. CVE-2016-3945

    High · CVSS 7.8EPSS 3.52%Fix available

    CVE-2016-3945

    Multiple integer overflows in the (1) cvt_by_strip and (2) cvt_by_tile functions in the tiff2rgba tool in LibTIFF 4.0.6 and earlier, when -b mode is enabled, allow remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted TIFF image, which triggers an out-of-bounds write.

    • Update to 4.0.3-7ubuntu0.6
    Published Updated
  4. CVE-2016-5875

    Not ratedFix available

    UBUNTU-CVE-2016-5875

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2016-5314. Reason: This candidate is a reservation duplicate of CVE-2016-5314. Notes: All CVE users should reference CVE-2016-5314 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    • Update to 4.0.3-7ubuntu0.6
    Published Updated
  5. CVE-2016-5320

    Not ratedFix available

    UBUNTU-CVE-2016-5320

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2016-5314. Reason: This candidate is a reservation duplicate of CVE-2016-5314. Notes: All CVE users should reference CVE-2016-5314 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    • Update to 4.0.3-7ubuntu0.6
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →