p PatchFirst

PatchFirst · Latest vulnerabilities

firefox vulnerabilities · Page 34

Vulnerabilities published for firefox in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 691

  1. CVE-2016-2839

    Medium · CVSS 6.5EPSS 1.79%Fix available

    CVE-2016-2839

    Mozilla Firefox before 48.0 and Firefox ESR 45.x before 45.3 on Linux make cairo _cairo_surface_get_extents calls that do not properly interact with libav header allocation in FFmpeg 0.10, which allows remote attackers to cause a denial of service (application crash) via a crafted video.

    • Update to 48.0+build2-0ubuntu0.16.04.1
    Published Updated
  2. CVE-2016-2837

    Medium · CVSS 6.3EPSS 4.58%Fix available

    CVE-2016-2837

    Heap-based buffer overflow in the ClearKey Content Decryption Module (CDM) in the Encrypted Media Extensions (EME) API in Mozilla Firefox before 48.0 and Firefox ESR 45.x before 45.3 might allow remote attackers to execute arbitrary code by providing a malformed video and leveraging a Gecko Media Plugin (GMP) sandbox bypass.

    • Update to 48.0+build2-0ubuntu0.16.04.1
    Published Updated
  3. CVE-2016-2836

    High · CVSS 8.8EPSS 2.89%Fix available

    CVE-2016-2836

    Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 48.0 and Firefox ESR 45.x before 45.3 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors related to Http2Session::Shutdown and SpdySession31::Shutdown, and other vectors.

    • Update to 48.0+build2-0ubuntu0.16.04.1
    Published Updated
  4. CVE-2016-2830

    Medium · CVSS 4.3EPSS 1.46%Fix available

    CVE-2016-2830

    Mozilla Firefox before 48.0 and Firefox ESR 45.x before 45.3 preserve the network connection used for favicon resource retrieval after the associated browser window is closed, which makes it easier for remote web servers to track users by observing network traffic from multiple IP addresses.

    • Update to 48.0+build2-0ubuntu0.16.04.1
    Published Updated
  5. CVE-2016-2831

    High · CVSS 8.8EPSS 1.35%Fix available

    CVE-2016-2831

    Mozilla Firefox before 47.0 and Firefox ESR 45.x before 45.2 do not ensure that the user approves the fullscreen and pointerlock settings, which allows remote attackers to cause a denial of service (UI outage), or conduct clickjacking or spoofing attacks, via a crafted web site.

    • Update to 47.0+build3-0ubuntu0.16.04.1
    Published Updated
  6. CVE-2016-2821

    High · CVSS 7.5EPSS 2.77%Fix available

    CVE-2016-2821

    Use-after-free vulnerability in the mozilla::dom::Element class in Mozilla Firefox before 47.0 and Firefox ESR 45.x before 45.2, when contenteditable mode is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) by triggering deletion of DOM elements that were created in the editor.

    • Update to 47.0+build3-0ubuntu0.16.04.1
    Published Updated
  7. CVE-2016-2818

    High · CVSS 8.8EPSS 3.87%Fix available

    CVE-2016-2818

    Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 47.0 and Firefox ESR 45.x before 45.2 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.

    • Update to 47.0+build3-0ubuntu0.16.04.1
    Published Updated
  8. USN-2936-3

    Not ratedFix available

    firefox regression

    USN-2936-1 fixed vulnerabilities in Firefox. The update caused an issue where a device update POST request was sent every time about:preferences#sync was shown. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Christian Holler, Tyson Smith, Phil Ringalda, Gary Kwong, Jesse Ruderman, Mats Palmgren, Carsten Book, Boris Zbarsky, David Bolter, Randell Jesup, Andrew McCreight, and Steve Fink discovered multiple memory safety issues in Firefox. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit these to cause a denial of service via applicatio

    • Update to 46.0.1+build1-0ubuntu0.16.04.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →