p PatchFirst

PatchFirst · Latest vulnerabilities

gitlab vulnerabilities · Page 46

Vulnerabilities published for gitlab in the last 30 days: 25. Listed in the KEV catalogue: 1.

Filter vulnerabilities
Clear filters

Vulnerabilities: 926

  1. CVE-2019-5883

    Critical · CVSS 9.1EPSS 1.5%No fix published

    CVE-2019-5883

    An Incorrect Access Control issue was discovered in GitLab Community and Enterprise Edition 6.0 and later but before 11.3.11, 11.4.x before 11.4.8, and 11.5.x before 11.5.1. The issue comments feature could allow a user to comment on an issue which they shouldn't be allowed to.

    Published Updated
  2. CVE-2019-10109

    Medium · CVSS 5.3EPSS 1.96%No fix published

    CVE-2019-10109

    An Information Exposure issue (issue 1 of 2) was discovered in GitLab Community and Enterprise Edition before 11.7.8, 11.8.x before 11.8.4, and 11.9.x before 11.9.2. EXIF geolocation data were not removed from images when uploaded to GitLab. As a result, anyone with access to the uploaded image could obtain its geolocation, device, and software version data (if present).

    Published Updated
  3. CVE-2019-5421

    Critical · CVSS 9.8EPSS 1.56%No fix published

    CVE-2019-5421

    Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

    Published Updated
  4. CVE-2017-0921

    High · CVSS 8.1EPSS 1.07%No fix published

    CVE-2017-0921

    GitLab Community and Enterprise Editions before 10.1.6, 10.2.6, and 10.3.4 are vulnerable to an unverified password change issue in the PasswordsController component resulting in potential account takeover if a victim's session is compromised.

    Published Updated
  5. CVE-2017-0919

    High · CVSS 7.5EPSS 1.08%No fix published

    CVE-2017-0919

    GitLab Community and Enterprise Editions before 10.1.6, 10.2.6, and 10.3.4 are vulnerable to an authorization bypass issue in the GitLab import component resulting in an attacker being able to perform operations under a group in which they were previously unauthorized.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →