CVE-2019-5421
CVE-2019-5421
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
CVSS 9.8 · Critical · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
devise ruby gem
- Versions
- 4.5.0 and earlier using the lockable module: Affected
No fix published
ruby-devise Debian:12
- Affected ranges
- ECOSYSTEM: < 4.5.0-3
Update to 4.5.0-3
gitlab Ubuntu:16.04:LTS
- Versions
- 8.4.3+dfsg-9
- 8.4.3+dfsg-12
- 8.5.8+dfsg-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-devise Ubuntu:18.04:LTS
- Versions
- 4.2.0-1
- 4.3.0-1
- 4.4.3-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-devise Ubuntu:20.04:LTS
- Affected ranges
- ECOSYSTEM: < 4.5.0-3
Update to 4.5.0-3