p PatchFirst

PatchFirst · Latest vulnerabilities

libxalan2-java vulnerabilities

Vulnerabilities published for libxalan2-java in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2022-34169

    High · CVSS 7.5EPSS 81.76%No fix published

    Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets

    The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →