p PatchFirst

PatchFirst · Latest vulnerabilities

linux-aws vulnerabilities · Page 6

Vulnerabilities published for linux-aws in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 614

  1. CVE-2020-13974

    High · CVSS 7.8EPSS 0.57%Fix available

    CVE-2020-13974

    An issue was discovered in the Linux kernel 4.4 through 5.7.1. drivers/tty/vt/keyboard.c has an integer overflow if k_ascii is called several times in a row, aka CID-b86dab054059. NOTE: Members in the community argue that the integer overflow does not lead to a security issue in this case.

    • Update to 4.4.0-1111.123
    Published Updated
  2. CVE-2020-10751

    Medium · CVSS 6.1EPSS 0.35%Fix available

    CVE-2020-10751

    A flaw was found in the Linux kernels SELinux LSM hook implementation before version 5.7, where it incorrectly assumed that an skb would only contain a single netlink message. The hook would incorrectly only validate the first netlink message in the skb and allow or deny the rest of the messages within the skb with the granted permission without further processing.

    • Update to 4.4.0-1109.120
    Published Updated
  3. CVE-2020-10711

    Medium · CVSS 5.9EPSS 3.08%Fix available

    CVE-2020-10711

    A NULL pointer dereference flaw was found in the Linux kernel's SELinux subsystem in versions before 5.7. This flaw occurs while importing the Commercial IP Security Option (CIPSO) protocol's category bitmap into the SELinux extensible bitmap via the' ebitmap_netlbl_import' routine. While processing the CIPSO restricted bitmap tag in the 'cipso_v4_parsetag_rbm' routine, it sets the security attribute to indicate that the category bitmap is present, even if it has not been allocated. This issue leads to a NULL pointer dereference issue while importing the same category bitmap into SELinux. This flaw allows a remote network user to crash the sy

    • Update to 4.4.0-1110.121
    Published Updated
  4. CVE-2020-10135

    Medium · CVSS 5.4EPSS 2.37%Fix available

    Bluetooth devices supporting BR/EDR v5.2 and earlier are vulnerable to impersonation attacks

    Legacy pairing and secure-connections pairing authentication in Bluetooth BR/EDR Core Specification v5.2 and earlier may allow an unauthenticated user to complete authentication without pairing credentials via adjacent access. An unauthenticated, adjacent attacker could impersonate a Bluetooth BR/EDR master or slave to pair with a previously paired remote device to successfully complete the authentication procedure without knowing the link key.

    • Update to 4.4.0-1118.132
    Published Updated
  5. CVE-2020-12826

    Medium · CVSS 5.3EPSS 0.71%Fix available

    CVE-2020-12826

    A signal access-control issue was discovered in the Linux kernel before 5.6.5, aka CID-7395ea4e65c2. Because exec_id in include/linux/sched.h is only 32 bits, an integer overflow can interfere with a do_notify_parent protection mechanism. A child process can send an arbitrary signal to a parent process in a different security domain. Exploitation limitations include the amount of elapsed time before an integer overflow occurs, and the lack of scenarios where signals to a parent process present a substantial operational threat.

    • Update to 4.4.0-1109.120
    Published Updated
  6. CVE-2020-10690

    Medium · CVSS 6.5EPSS 0.36%Fix available

    CVE-2020-10690

    There is a use-after-free in kernel versions before 5.5 due to a race condition between the release of ptp_clock and cdev while resource deallocation. When a (high privileged) process allocates a ptp device file (like /dev/ptpX) and voluntarily goes to sleep. During this time if the underlying device is removed, it can cause an exploitable condition as the process wakes up to terminate and clean all attached files. The system crashes due to the cdev structure being invalid (as already freed) which is pointed to by the inode.

    • Update to 4.4.0-1110.121
    Published Updated
  7. CVE-2020-12656

    Medium · CVSS 5.5EPSS 0.33%Fix available

    CVE-2020-12656

    gss_mech_free in net/sunrpc/auth_gss/gss_mech_switch.c in the rpcsec_gss_krb5 implementation in the Linux kernel through 5.6.10 lacks certain domain_release calls, leading to a memory leak. Note: This was disputed with the assertion that the issue does not grant any access not already available. It is a problem that on unloading a specific kernel module some memory is leaked, but loading kernel modules is a privileged operation. A user could also write a kernel module to consume any amount of memory they like and load that replicating the effect of this bug

    • Update to 4.4.0-1111.123
    Published Updated
  8. CVE-2020-12653

    High · CVSS 7.8EPSS 0.45%Fix available

    CVE-2020-12653

    An issue was found in Linux kernel before 5.5.4. The mwifiex_cmd_append_vsie_tlv() function in drivers/net/wireless/marvell/mwifiex/scan.c allows local users to gain privileges or cause a denial of service because of an incorrect memcpy and buffer overflow, aka CID-b70261a288ea.

    • Update to 4.4.0-1105.116
    Published Updated
  9. CVE-2020-12652

    Medium · CVSS 4.1EPSS 0.33%Fix available

    CVE-2020-12652

    The __mptctl_ioctl function in drivers/message/fusion/mptctl.c in the Linux kernel before 5.4.14 allows local users to hold an incorrect lock during the ioctl operation and trigger a race condition, i.e., a "double fetch" vulnerability, aka CID-28d76df18f0a. NOTE: the vendor states "The security impact of this bug is not as bad as it could have been because these operations are all privileged and root already has enormous destructive power."

    • Update to 4.4.0-1102.113
    Published Updated
  10. CVE-2020-12114

    Medium · CVSS 4.7EPSS 0.44%Fix available

    CVE-2020-12114

    A pivot_root race condition in fs/namespace.c in the Linux kernel 4.4.x before 4.4.221, 4.9.x before 4.9.221, 4.14.x before 4.14.178, 4.19.x before 4.19.119, and 5.x before 5.3 allows local users to cause a denial of service (panic) by corrupting a mountpoint reference counter.

    • Update to 4.4.0-1109.120
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →