p PatchFirst

PatchFirst · Latest vulnerabilities

moodle vulnerabilities

Vulnerabilities published for moodle in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 5

  1. CVE-2016-2158

    Medium · CVSS 4.3EPSS 1.71%Fix available

    CVE-2016-2158

    lib/ajax/getnavbranch.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3, when the forcelogin feature is enabled, allows remote attackers to obtain sensitive category-detail information from the navigation branch by leveraging the guest role for an Ajax request.

    • Update to 3.0.3+dfsg-0ubuntu1
    Published Updated
  2. CVE-2016-2157

    High · CVSS 8.8EPSS 0.97%Fix available

    CVE-2016-2157

    Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote attackers to hijack the authentication of administrators for requests that manage Assignment plugins.

    • Update to 3.0.3+dfsg-0ubuntu1
    Published Updated
  3. CVE-2016-2156

    Medium · CVSS 4.3EPSS 1.69%Fix available

    CVE-2016-2156

    calendar/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 provides calendar-event data without considering whether an activity is hidden, which allows remote authenticated users to obtain sensitive information via a web-service request.

    • Update to 3.0.3+dfsg-0ubuntu1
    Published Updated
  4. CVE-2016-2155

    Medium · CVSS 4.3EPSS 1.61%Fix available

    CVE-2016-2155

    The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

    • Update to 3.0.3+dfsg-0ubuntu1
    Published Updated
  5. CVE-2016-2154

    Medium · CVSS 4.3EPSS 1.69%Fix available

    CVE-2016-2154

    admin/tool/monitor/lib.php in Event Monitor in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to discover hidden course names by subscribing to a rule.

    • Update to 3.0.3+dfsg-0ubuntu1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →