p PatchFirst

PatchFirst · Latest vulnerabilities

php7.0 vulnerabilities · Page 6

Vulnerabilities published for php7.0 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 112

  1. CVE-2016-4543

    Critical · CVSS 9.8EPSS 11.86%Fix available

    CVE-2016-4543

    The exif_process_IFD_in_JPEG function in ext/exif/exif.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 does not validate IFD sizes, which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via crafted header data.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  2. CVE-2016-4542

    Critical · CVSS 9.8EPSS 6.06%Fix available

    CVE-2016-4542

    The exif_process_IFD_TAG function in ext/exif/exif.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 does not properly construct spprintf arguments, which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via crafted header data.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  3. CVE-2016-4541

    Critical · CVSS 9.8EPSS 6.06%Fix available

    CVE-2016-4541

    The grapheme_strpos function in ext/intl/grapheme/grapheme_string.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a negative offset.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  4. CVE-2016-4540

    Critical · CVSS 9.8EPSS 6.06%Fix available

    CVE-2016-4540

    The grapheme_stripos function in ext/intl/grapheme/grapheme_string.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a negative offset.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  5. CVE-2016-4539

    Critical · CVSS 9.8EPSS 6.06%Fix available

    CVE-2016-4539

    The xml_parse_into_struct function in ext/xml/xml.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 allows remote attackers to cause a denial of service (buffer under-read and segmentation fault) or possibly have unspecified other impact via crafted XML data in the second argument, leading to a parser level of zero.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  6. CVE-2016-4538

    Critical · CVSS 9.8EPSS 6.06%Fix available

    CVE-2016-4538

    The bcpowmod function in ext/bcmath/bcmath.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 modifies certain data structures without considering whether they are copies of the _zero_, _one_, or _two_ global variable, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted call.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  7. CVE-2016-4537

    Critical · CVSS 9.8EPSS 5.72%Fix available

    CVE-2016-4537

    The bcpowmod function in ext/bcmath/bcmath.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 accepts a negative integer for the scale argument, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted call.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  8. CVE-2016-4073

    Critical · CVSS 9.8EPSS 7.09%Fix available

    CVE-2016-4073

    Multiple integer overflows in the mbfl_strcut function in ext/mbstring/libmbfl/mbfl/mbfilter.c in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted mb_strcut call.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  9. CVE-2016-4070

    High · CVSS 7.5EPSS 5.72%Fix available

    CVE-2016-4070

    Integer overflow in the php_raw_url_encode function in ext/standard/url.c in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5 allows remote attackers to cause a denial of service (application crash) via a long string to the rawurlencode function. NOTE: the vendor says "Not sure if this qualifies as security issue (probably not).

    • Update to 7.0.4-7ubuntu2.1
    Published Updated
  10. CVE-2015-8865

    High · CVSS 7.3EPSS 5.48%Fix available

    CVE-2015-8865

    The file_check_mem function in funcs.c in file before 5.23, as used in the Fileinfo component in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5, mishandles continuation-level jumps, which allows context-dependent attackers to cause a denial of service (buffer overflow and application crash) or possibly execute arbitrary code via a crafted magic file.

    • Update to 7.0.4-7ubuntu2.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →