p PatchFirst

PatchFirst · Latest vulnerabilities

webkit2gtk vulnerabilities · Page 37

Vulnerabilities published for webkit2gtk in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 733

  1. CVE-2016-4622

    High · CVSS 8.8EPSS 20.37%Fix available

    CVE-2016-4622

    WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4589, CVE-2016-4623, and CVE-2016-4624.

    • Update to 2.12.5-0ubuntu0.16.04.1
    Published Updated
  2. CVE-2016-4589

    High · CVSS 8.8EPSS 2.82%Fix available

    CVE-2016-4589

    WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4622, CVE-2016-4623, and CVE-2016-4624.

    • Update to 2.12.5-0ubuntu0.16.04.1
    Published Updated
  3. CVE-2016-4585

    Medium · CVSS 6.1EPSS 1.92%Fix available

    CVE-2016-4585

    Cross-site scripting (XSS) vulnerability in the WebKit Page Loading implementation in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to inject arbitrary web script or HTML via an HTTP response specifying redirection that is mishandled by Safari.

    • Update to 2.12.5-0ubuntu0.16.04.1
    Published Updated
  4. CVE-2016-1857

    High · CVSS 8.8EPSS 2.89%Fix available

    CVE-2016-1857

    WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1856.

    • Update to 2.12.5-0ubuntu0.16.04.1
    Published Updated
  5. CVE-2016-1856

    High · CVSS 8.8EPSS 2.59%Fix available

    CVE-2016-1856

    WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1857.

    • Update to 2.12.5-0ubuntu0.16.04.1
    Published Updated
  6. CVE-2016-1854

    High · CVSS 8.8EPSS 2.58%Fix available

    CVE-2016-1854

    WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1855, CVE-2016-1856, and CVE-2016-1857.

    • Update to 2.12.5-0ubuntu0.16.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →