p PatchFirst

PatchFirst · Latest vulnerabilities

wireshark vulnerabilities · Page 10

Vulnerabilities published for wireshark in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 253

  1. CVE-2016-4417

    Medium · CVSS 5.9EPSS 1.37%Fix available

    CVE-2016-4417

    Off-by-one error in epan/dissectors/packet-gsm_abis_oml.c in the GSM A-bis OML dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers a 0xff tag value.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated
  2. CVE-2016-4084

    Medium · CVSS 5.9EPSS 2.14%Fix available

    CVE-2016-4084

    Integer signedness error in epan/dissectors/packet-mswsp.c in the MS-WSP dissector in Wireshark 2.0.x before 2.0.3 allows remote attackers to cause a denial of service (integer overflow and application crash) via a crafted packet that triggers an unexpected array size.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated
  3. CVE-2016-4082

    Medium · CVSS 5.9EPSS 2.39%Fix available

    CVE-2016-4082

    epan/dissectors/packet-gsm_cbch.c in the GSM CBCH dissector in Wireshark 1.12.x before 1.12.11 and 2.0.x before 2.0.3 uses the wrong variable to index an array, which allows remote attackers to cause a denial of service (out-of-bounds access and application crash) via a crafted packet.

    • Update to 2.2.6+g32dac6a-2ubuntu0.16.04
    Published Updated
  4. CVE-2016-4080

    Medium · CVSS 5.9EPSS 2.12%Fix available

    CVE-2016-4080

    epan/dissectors/packet-pktc.c in the PKTC dissector in Wireshark 1.12.x before 1.12.11 and 2.0.x before 2.0.3 misparses timestamp fields, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

    • Update to 2.2.6+g32dac6a-2ubuntu0.16.04
    Published Updated
  5. CVE-2016-4078

    Medium · CVSS 5.9EPSS 2.12%Fix available

    CVE-2016-4078

    The IEEE 802.11 dissector in Wireshark 1.12.x before 1.12.11 and 2.0.x before 2.0.3 does not properly restrict element lists, which allows remote attackers to cause a denial of service (deep recursion and application crash) via a crafted packet, related to epan/dissectors/packet-capwap.c and epan/dissectors/packet-ieee80211.c.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated
  6. CVE-2016-2529

    Medium · CVSS 5.5EPSS 1.23%Fix available

    CVE-2016-2529

    The iseries_check_file_type function in wiretap/iseries.c in the iSeries file parser in Wireshark 2.0.x before 2.0.2 does not consider that a line may lack the "OBJECT PROTOCOL" substring, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted file.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated
  7. CVE-2016-2528

    Medium · CVSS 5.9EPSS 2.21%Fix available

    CVE-2016-2528

    The dissect_nhdr_extopt function in epan/dissectors/packet-lbmc.c in the LBMC dissector in Wireshark 2.0.x before 2.0.2 does not validate length values, which allows remote attackers to cause a denial of service (stack-based buffer overflow and application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated
  8. CVE-2016-2527

    Medium · CVSS 5.5EPSS 1.43%Fix available

    CVE-2016-2527

    wiretap/nettrace_3gpp_32_423.c in the 3GPP TS 32.423 Trace file parser in Wireshark 2.0.x before 2.0.2 does not ensure that a '\0' character is present at the end of certain strings, which allows remote attackers to cause a denial of service (stack-based buffer overflow and application crash) via a crafted file.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated
  9. CVE-2016-2522

    Medium · CVSS 5.9EPSS 2.08%Fix available

    CVE-2016-2522

    The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated
  10. CVE-2016-2521

    High · CVSS 7.8EPSS 0.4%Fix available

    CVE-2016-2521

    Untrusted search path vulnerability in the WiresharkApplication class in ui/qt/wireshark_application.cpp in Wireshark 1.12.x before 1.12.10 and 2.0.x before 2.0.2 on Windows allows local users to gain privileges via a Trojan horse riched20.dll.dll file in the current working directory, related to use of QLibrary.

    • Update to 2.6.3-1~ubuntu16.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →