p PatchFirst

PatchFirst · Latest vulnerabilities

linux-gcp-edge vulnerabilities · Page 27

Vulnerabilities published for linux-gcp-edge in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 553

  1. CVE-2019-9162

    High · CVSS 7.8EPSS 1.09%Public exploitFix available

    CVE-2019-9162

    In the Linux kernel before 4.20.12, net/ipv4/netfilter/nf_nat_snmp_basic_main.c in the SNMP NAT module has insufficient ASN.1 length checks (aka an array index error), making out-of-bounds read and write operations possible, leading to an OOPS or local privilege escalation. This affects snmp_version and snmp_helper.

    • Update to 4.18.0-1008.9~18.04.1
    Published Updated
  2. CVE-2018-16880

    Medium · CVSS 5.9EPSS 0.56%Fix available

    CVE-2018-16880

    A flaw was found in the Linux kernel's handle_rx() function in the [vhost_net] driver. A malicious virtual guest, under specific conditions, can trigger an out-of-bounds write in a kmalloc-8 slab on a virtual host which may lead to a kernel memory corruption and a system panic. Due to the nature of the flaw, privilege escalation cannot be fully ruled out. Versions from v4.16 and newer are vulnerable.

    • Update to 4.18.0-1007.8~18.04.1
    Published Updated
  3. CVE-2018-16882

    Medium · CVSS 6.1EPSS 0.36%Fix available

    CVE-2018-16882

    A use-after-free issue was found in the way the Linux kernel's KVM hypervisor processed posted interrupts when nested(=1) virtualization is enabled. In nested_get_vmcs12_pages(), in case of an error while processing posted interrupt address, it unmaps the 'pi_desc_page' without resetting 'pi_desc' descriptor address, which is later used in pi_test_and_clear_on(). A guest user/process could use this flaw to crash the host kernel resulting in DoS or potentially gain privileged access to a system. Kernel versions before 4.14.91 and before 4.19.13 are vulnerable.

    • Update to 4.18.0-1006.7~18.04.1
    Published Updated
  4. CVE-2018-16884

    Medium · CVSS 6.5EPSS 1.46%Fix available

    CVE-2018-16884

    A flaw was found in the Linux kernel's NFS41+ subsystem. NFS41+ shares mounted in different network namespaces at the same time can make bc_svc_process() use wrong back-channel IDs and cause a use-after-free vulnerability. Thus a malicious container user can cause a host kernel memory corruption and a system panic. Due to the nature of the flaw, privilege escalation cannot be fully ruled out.

    • Update to 4.18.0-1011.12~18.04.1
    Published Updated
  5. CVE-2018-18397

    Medium · CVSS 5.5EPSS 0.51%Fix available

    CVE-2018-18397

    The userfaultfd implementation in the Linux kernel before 4.19.7 mishandles access control for certain UFFDIO_ ioctl calls, as demonstrated by allowing local users to write data into holes in a tmpfs file (if the user has read-only access to that file, and that file contains holes), related to fs/userfaultfd.c and mm/userfaultfd.c.

    • Update to 4.18.0-1007.8~18.04.1
    Published Updated
  6. CVE-2018-19854

    Medium · CVSS 4.7EPSS 0.45%Fix available

    CVE-2018-19854

    An issue was discovered in the Linux kernel before 4.19.3. crypto_report_one() and related functions in crypto/crypto_user.c (the crypto user configuration API) do not fully initialize structures that are copied to userspace, potentially leaking sensitive memory to user programs. NOTE: this is a CVE-2013-2547 regression but with easier exploitability because the attacker does not need a capability (however, the system must have the CONFIG_CRYPTO_USER kconfig option).

    • Update to 4.18.0-1006.7~18.04.1
    Published Updated
  7. CVE-2018-18710

    Medium · CVSS 5.5EPSS 0.5%Fix available

    CVE-2018-18710

    An issue was discovered in the Linux kernel through 4.19. An information leak in cdrom_ioctl_select_disc in drivers/cdrom/cdrom.c could be used by local attackers to read kernel memory because a cast from unsigned long to int interferes with bounds checking. This is similar to CVE-2018-10940 and CVE-2018-16658.

    • Update to 4.18.0-1005.6~18.04.1
    Published Updated
  8. CVE-2018-17977

    Medium · CVSS 4.4EPSS 0.4%No fix published

    CVE-2018-17977

    The Linux kernel 4.14.67 mishandles certain interaction among XFRM Netlink messages, IPPROTO_AH packets, and IPPROTO_IP packets, which allows local users to cause a denial of service (memory consumption and system hang) by leveraging root access to execute crafted applications, as demonstrated on CentOS 7.

    Published Updated
  9. CVE-2018-14625

    Medium · CVSS 5.3EPSS 0.35%No fix published

    CVE-2018-14625

    A flaw was found in the Linux Kernel where an attacker may be able to have an uncontrolled read to kernel-memory from within a vm guest. A race condition between connect() and close() function may allow an attacker using the AF_VSOCK protocol to gather a 4 byte information leak or possibly intercept or corrupt AF_VSOCK messages destined to other clients.

    Published Updated
  10. CVE-2018-1121

    Low · CVSS 3.9EPSS 4.11%Public exploitNo fix published

    CVE-2018-1121

    procps-ng, procps is vulnerable to a process hiding through race condition. Since the kernel's proc_pid_readdir() returns PID entries in ascending numeric order, a process occupying a high PID can use inotify events to determine when the process list is being scanned, and fork/exec to obtain a lower PID, thus avoiding enumeration. An unprivileged attacker can hide a process from procps-ng's utilities by exploiting a race condition in reading /proc/PID entries. This vulnerability affects procps and procps-ng up to version 3.3.15, newer versions might be affected also.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →