p PatchFirst

PatchFirst · Latest vulnerabilities

linux-oem-osp1 vulnerabilities · Page 4

Vulnerabilities published for linux-oem-osp1 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 248

  1. CVE-2020-12114

    Medium · CVSS 4.7EPSS 0.44%Fix available

    CVE-2020-12114

    A pivot_root race condition in fs/namespace.c in the Linux kernel 4.4.x before 4.4.221, 4.9.x before 4.9.221, 4.14.x before 4.14.178, 4.19.x before 4.19.119, and 5.x before 5.3 allows local users to cause a denial of service (panic) by corrupting a mountpoint reference counter.

    • Update to 5.0.0-1059.64
    Published Updated
  2. CVE-2019-15794

    High · CVSS 7.1EPSS 1.16%Public exploitFix available

    Reference counting error in overlayfs/shiftfs error path when used in conjuction with aufs

    Overlayfs in the Linux kernel and shiftfs, a non-upstream patch to the Linux kernel included in the Ubuntu 5.0 and 5.3 kernel series, both replace vma->vm_file in their mmap handlers. On error the original value is not restored, and the reference is put for the file to which vm_file points. On upstream kernels this is not an issue, as no callers dereference vm_file following after call_mmap() returns an error. However, the aufs patchs change mmap_region() to replace the fput() using a local variable with vma_fput(), which will fput() vm_file, leading to a refcount underflow.

    • Update to 5.0.0-1030.34
    Published Updated
  3. CVE-2020-0067

    Medium · CVSS 4.4EPSS 0.48%Fix available

    CVE-2020-0067

    In f2fs_xattr_generic_list of xattr.c, there is a possible out of bounds read due to a missing bounds check. This could lead to local information disclosure with System execution privileges needed. User interaction is not required for exploitation.Product: Android. Versions: Android kernel. Android ID: A-120551147.

    • Update to 5.0.0-1059.64
    Published Updated
  4. CVE-2020-2732

    Medium · CVSS 5.8EPSS 0.93%Fix available

    CVE-2020-2732

    A flaw was discovered in the way that the KVM hypervisor handled instruction emulation for an L2 guest when nested virtualisation is enabled. Under some circumstances, an L2 guest may trick the L0 guest into accessing sensitive L1 resources that should be inaccessible to the L2 guest.

    • Update to 5.0.0-1043.48
    Published Updated
  5. CVE-2020-11609

    Medium · CVSS 4.3EPSS 0.59%Fix available

    CVE-2020-11609

    An issue was discovered in the stv06xx subsystem in the Linux kernel before 5.6.1. drivers/media/usb/gspca/stv06xx/stv06xx.c and drivers/media/usb/gspca/stv06xx/stv06xx_pb0100.c mishandle invalid descriptors, as demonstrated by a NULL pointer dereference, aka CID-485b06aadb93.

    • Update to 5.0.0-1052.57
    Published Updated
  6. CVE-2020-11565

    Medium · CVSS 6EPSS 0.52%Fix available

    CVE-2020-11565

    An issue was discovered in the Linux kernel through 5.6.2. mpol_parse_str in mm/mempolicy.c has a stack-based out-of-bounds write because an empty nodelist is mishandled during mount option parsing, aka CID-aa9f7d5172fa. NOTE: Someone in the security community disagrees that this is a vulnerability because the issue “is a bug in parsing mount options which can only be specified by a privileged user, so triggering the bug does not grant any powers not already held.”

    • Update to 5.0.0-1052.57
    Published Updated
  7. CVE-2020-11494

    Medium · CVSS 4.4EPSS 0.72%Fix available

    CVE-2020-11494

    An issue was discovered in slc_bump in drivers/net/can/slcan.c in the Linux kernel 3.16 through 5.6.2. It allows attackers to read uninitialized can_frame data, potentially containing sensitive information from kernel stack memory, if the configuration lacks CONFIG_INIT_STACK_ALL, aka CID-b9258a2cece4.

    • Update to 5.0.0-1052.57
    Published Updated
  8. CVE-2019-3016

    Medium · CVSS 6.2EPSS 0.62%Fix available

    CVE-2019-3016

    In a Linux KVM guest that has PV TLB enabled, a process in the guest kernel may be able to read memory locations from another process in the same guest. This problem is limit to the host running linux kernel 4.10 with a guest running linux kernel 4.16 or later. The problem mainly affects AMD processors but Intel CPUs cannot be ruled out.

    • Update to 5.0.0-1043.48
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →