p PatchFirst

PatchFirst · Latest vulnerabilities

lxml vulnerabilities

Vulnerabilities published for lxml in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2021-43818

    High · CVSS 8.2EPSS 2.66%Fix available

    HTML Cleaner allows crafted and SVG embedded scripts to pass through

    lxml is a library for processing XML and HTML in the Python language. Prior to version 4.6.5, the HTML Cleaner in lxml.html lets certain crafted script content pass through, as well as script content in SVG files embedded using data URIs. Users that employ the HTML cleaner in a security relevant context should upgrade to lxml 4.6.5 to receive a patch. There are no known workarounds available.

    • Update to 4.2.1-1ubuntu0.6
    Published Updated
  2. CVE-2021-28957

    Medium · CVSS 6.1EPSS 4.04%Fix available

    CVE-2021-28957

    An XSS vulnerability was discovered in python-lxml's clean module versions before 4.6.3. When disabling the safe_attrs_only and forms arguments, the Cleaner class does not remove the formaction attribute allowing for JS to bypass the sanitizer. A remote attacker could exploit this flaw to run arbitrary JS code on users who interact with incorrectly sanitized HTML. This issue is patched in lxml 4.6.3.

    • Update to 4.2.1-1ubuntu0.4
    Published Updated
  3. CVE-2020-27783

    Medium · CVSS 6.1EPSS 3.98%Fix available

    CVE-2020-27783

    A XSS vulnerability was discovered in python-lxml's clean module. The module's parser didn't properly imitate browsers, which caused different behaviors between the sanitizer and the user's page. A remote attacker could exploit this flaw to run arbitrary HTML/JS code.

    • Update to 4.2.1-1ubuntu0.3
    Published Updated
  4. CVE-2018-19787

    Medium · CVSS 6.1EPSS 2.44%Fix available

    CVE-2018-19787

    An issue was discovered in lxml before 4.2.5. lxml/html/clean.py in the lxml.html.clean module does not remove javascript: URLs that use escaping, allowing a remote attacker to conduct XSS attacks, as demonstrated by "j a v a s c r i p t:" in Internet Explorer. This is a similar issue to CVE-2014-3146.

    • Update to 4.2.1-1ubuntu0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →