p PatchFirst

PatchFirst · Latest vulnerabilities

mozjs52 vulnerabilities · Page 82

Vulnerabilities published for mozjs52 in the last 30 days: 257. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1727

  1. CVE-2019-9815

    High · CVSS 8.1EPSS 1.83%No fix published

    CVE-2019-9815

    If hyperthreading is not disabled, a timing attack vulnerability exists, similar to previous Spectre attacks. Apple has shipped macOS 10.14.5 with an option to disable hyperthreading in applications running untrusted code in a thread through a new sysctl. Firefox now makes use of it on the main thread and any worker threads. *Note: users need to update to macOS 10.14.5 in order to take advantage of this change.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    Published Updated
  2. CVE-2019-9816

    Medium · CVSS 5.9EPSS 6.15%Public exploitNo fix published

    CVE-2019-9816

    A possible vulnerability exists where type confusion can occur when manipulating JavaScript objects in object groups, allowing for the bypassing of security checks within these groups. *Note: this vulnerability has only been demonstrated with UnboxedObjects, which are disabled by default on all supported releases.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    Published Updated
  3. CVE-2019-9818

    High · CVSS 8.3EPSS 0.95%No fix published

    CVE-2019-9818

    A race condition is present in the crash generation server used to generate data for the crash reporter. This issue can lead to a use-after-free in the main process, resulting in a potentially exploitable crash and a sandbox escape. *Note: this vulnerability only affects Windows. Other operating systems are unaffected.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    Published Updated
  4. CVE-2019-11691

    Critical · CVSS 9.8EPSS 1.56%No fix published

    CVE-2019-11691

    A use-after-free vulnerability can occur when working with XMLHttpRequest (XHR) in an event loop, causing the XHR main thread to be called after it has been freed. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    Published Updated
  5. CVE-2019-11693

    Critical · CVSS 9.8EPSS 2.41%No fix published

    CVE-2019-11693

    The bufferdata function in WebGL is vulnerable to a buffer overflow with specific graphics drivers on Linux. This could result in malicious content freezing a tab or triggering a potentially exploitable crash. *Note: this issue only occurs on Linux. Other operating systems are unaffected.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    Published Updated
  6. CVE-2019-11694

    High · CVSS 7.5EPSS 1.51%No fix published

    CVE-2019-11694

    A vulnerability exists in the Windows sandbox where an uninitialized value in memory can be leaked to a renderer from a broker when making a call to access an otherwise unavailable file. This results in the potential leaking of information stored at that memory location. *Note: this issue only occurs on Windows. Other operating systems are unaffected.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    Published Updated
  7. CVE-2019-11695

    Medium · CVSS 4.3EPSS 0.73%No fix published

    CVE-2019-11695

    A custom cursor defined by scripting on a site can position itself over the addressbar to spoof the actual cursor when it should not be allowed outside of the primary web content area. This could be used by a malicious site to trick users into clicking on permission prompts, doorhanger notifications, or other buttons inadvertently if the location is spoofed over the user interface. This vulnerability affects Firefox < 67.

    Published Updated
  8. CVE-2019-11696

    High · CVSS 7.8EPSS 0.84%No fix published

    CVE-2019-11696

    Files with the .JNLP extension used for "Java web start" applications are not treated as executable content for download prompts even though they can be executed if Java is installed on the local system. This could allow users to mistakenly launch an executable binary locally. This vulnerability affects Firefox < 67.

    Published Updated
  9. CVE-2019-11697

    Medium · CVSS 6.5EPSS 0.85%No fix published

    CVE-2019-11697

    If the ALT and "a" keys are pressed when users receive an extension installation prompt, the extension will be installed without the install prompt delay that keeps the prompt visible in order for users to accept or decline the installation. A malicious web page could use this with spoofing on the page to trick users into installing a malicious extension. This vulnerability affects Firefox < 67.

    Published Updated
  10. CVE-2019-11698

    Medium · CVSS 5.3EPSS 1.35%No fix published

    CVE-2019-11698

    If a crafted hyperlink is dragged and dropped to the bookmark bar or sidebar and the resulting bookmark is subsequently dragged and dropped into the web content area, an arbitrary query of a user's browser history can be run and transmitted to the content page via drop event data. This allows for the theft of browser history by a malicious site. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    Published Updated
  11. CVE-2019-11701

    Medium · CVSS 6.1EPSS 0.64%No fix published

    CVE-2019-11701

    The default webcal: protocol handler will load a web site vulnerable to cross-site scripting (XSS) attacks. This default was left in place as a legacy feature and has now been removed. *Note: this issue only affects users with an account on the vulnerable service. Other users are unaffected.*. This vulnerability affects Firefox < 67.

    Published Updated
  12. CVE-2019-11707

    High · CVSS 8.8EPSS 37.95%In KEVPublic exploitNo fix published

    CVE-2019-11707

    A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 60.7.1, Firefox < 67.0.3, and Thunderbird < 60.7.2.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →