p PatchFirst

PatchFirst · Latest vulnerabilities

nginx vulnerabilities

Vulnerabilities published for nginx in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2022-41742

    High · CVSS 7.1EPSS 1.18%Fix available

    NGINX ngx_http_mp4_module vulnerability CVE-2022-41742

    NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video

    • Update to 1.14.0-0ubuntu1.11
    Published Updated
  2. CVE-2022-41741

    High · CVSS 7EPSS 0.81%Fix available

    NGINX ngx_http_mp4_module vulnerability CVE-2022-41741

    NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file wi

    • Update to 1.14.0-0ubuntu1.11
    Published Updated
  3. CVE-2021-3618

    High · CVSS 7.4EPSS 2.03%Fix available

    CVE-2021-3618

    ALPACA is an application layer protocol content confusion attack, exploiting TLS servers implementing different protocols but using compatible certificates, such as multi-domain or wildcard certificates. A MiTM attacker having access to victim's traffic at the TCP/IP layer can redirect traffic from one subdomain to another, resulting in a valid TLS session. This breaks the authentication of TLS and cross-protocol attacks may be possible where the behavior of one protocol service may compromise the other at the application layer.

    • Update to 1.14.0-0ubuntu1.10
    Published Updated
  4. CVE-2019-9516

    High · CVSS 7.5EPSS 56.26%Fix available

    Some HTTP/2 implementations are vulnerable to a header leak, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to a header leak, potentially leading to a denial of service. The attacker sends a stream of headers with a 0-length header name and 0-length header value, optionally Huffman encoded into 1-byte or greater headers. Some implementations allocate memory for these headers and keep the allocation alive until the session dies. This can consume excess memory.

    • Update to 1.14.0-0ubuntu1.4
    Published Updated
  5. CVE-2019-9513

    High · CVSS 7.5EPSS 81.56%Fix available

    Some HTTP/2 implementations are vulnerable to resource loops, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to resource loops, potentially leading to a denial of service. The attacker creates multiple request streams and continually shuffles the priority of the streams in a way that causes substantial churn to the priority tree. This can consume excess CPU.

    • Update to 1.14.0-0ubuntu1.4
    Published Updated
  6. CVE-2019-9511

    High · CVSS 7.5EPSS 59.55%Fix available

    Some HTTP/2 implementations are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service. The attacker requests a large amount of data from a specified resource over multiple streams. They manipulate window size and stream priority to force the server to queue the data in 1-byte chunks. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

    • Update to 1.14.0-0ubuntu1.4
    Published Updated
  7. CVE-2018-16845

    High · CVSS 8.2EPSS 9.84%Fix available

    CVE-2018-16845

    nginx before versions 1.15.6, 1.14.1 has a vulnerability in the ngx_http_mp4_module, which might allow an attacker to cause infinite loop in a worker process, cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted mp4 file. The issue only affects nginx if it is built with the ngx_http_mp4_module (the module is not built by default) and the .mp4. directive is used in the configuration file. Further, the attack is only possible if an attacker is able to trigger processing of a specially crafted mp4 file with the ngx_http_mp4_module.

    • Update to 1.14.0-0ubuntu1.2
    Published Updated
  8. CVE-2018-16844

    Medium · CVSS 5.3EPSS 12.73%Fix available

    CVE-2018-16844

    nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive CPU usage. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.

    • Update to 1.14.0-0ubuntu1.2
    Published Updated
  9. CVE-2018-16843

    Medium · CVSS 5.3EPSS 47.98%Fix available

    CVE-2018-16843

    nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive memory consumption. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.

    • Update to 1.14.0-0ubuntu1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →