p PatchFirst

PatchFirst · Latest vulnerabilities

opensips vulnerabilities · Page 2

Vulnerability published for opensips in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 21

  1. CVE-2023-27596

    High · CVSS 7.5EPSS 0.74%No fix published

    OpenSIPS has vulnerability in the codec_delete_XX() functions

    OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →