p PatchFirst

PatchFirst · Latest vulnerabilities

php7.2 vulnerabilities · Page 4

Vulnerabilities published for php7.2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 66

  1. CVE-2018-10545

    Medium · CVSS 4.7EPSS 0.79%Fix available

    CVE-2018-10545

    An issue was discovered in PHP before 5.6.35, 7.0.x before 7.0.29, 7.1.x before 7.1.16, and 7.2.x before 7.2.4. Dumpable FPM child processes allow bypassing opcache access controls because fpm_unix.c makes a PR_SET_DUMPABLE prctl call, allowing one user (in a multiuser environment) to obtain sensitive information from the process memory of a second user's PHP applications by running gcore on the PID of the PHP-FPM worker process.

    • Update to 7.2.5-0ubuntu0.18.04.1
    Published Updated
  2. CVE-2018-7584

    Critical · CVSS 9.8EPSS 87.35%Public exploitFix available

    CVE-2018-7584

    In PHP through 5.6.33, 7.0.x before 7.0.28, 7.1.x through 7.1.14, and 7.2.x through 7.2.2, there is a stack-based buffer under-read while parsing an HTTP response in the php_stream_url_wrap_http_ex function in ext/standard/http_fopen_wrapper.c. This subsequently results in copying a large string.

    • Update to 7.2.3-1ubuntu1
    Published Updated
  3. CVE-2015-9253

    Medium · CVSS 6.5EPSS 4.18%Fix available

    CVE-2015-9253

    An issue was discovered in PHP 7.3.x before 7.3.0alpha3, 7.2.x before 7.2.8, and before 7.1.20. The php-fpm master process restarts a child process in an endless loop when using program execution functions (e.g., passthru, exec, shell_exec, or system) with a non-blocking STDIN stream, causing this master process to consume 100% of the CPU, and consume disk space with a large volume of error logs, as demonstrated by an attack by a customer of a shared-hosting facility.

    • Update to 7.2.10-0ubuntu0.18.04.1
    Published Updated
  4. CVE-2017-8923

    Critical · CVSS 9.8EPSS 7.19%Fix available

    CVE-2017-8923

    The zend_string_extend function in Zend/zend_string.h in PHP through 7.1.5 does not prevent changes to string objects that result in a negative length, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact by leveraging a script's use of .= with a long string.

    • Update to 7.2.24-0ubuntu0.18.04.11
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →