p PatchFirst

PatchFirst · Latest vulnerabilities

php7.2 vulnerabilities · Page 3

Vulnerabilities published for php7.2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 66

  1. CVE-2019-9637

    High · CVSS 7.5EPSS 7.35%Fix available

    CVE-2019-9637

    An issue was discovered in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. Due to the way rename() across filesystems is implemented, it is possible that file being renamed is briefly available with wrong permissions while the rename is ongoing, thus enabling unauthorized users to access the data.

    • Update to 7.2.15-0ubuntu0.18.04.2
    Published Updated
  2. CVE-2019-9024

    High · CVSS 7.5EPSS 7.12%Fix available

    CVE-2019-9024

    An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. xmlrpc_decode() can allow a hostile XMLRPC server to cause PHP to read memory outside of allocated areas in base64_decode_xmlrpc in ext/xmlrpc/libxmlrpc/base64.c.

    • Update to 7.2.15-0ubuntu0.18.04.1
    Published Updated
  3. CVE-2019-9023

    Critical · CVSS 9.8EPSS 9.32%Fix available

    CVE-2019-9023

    An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A number of heap-based buffer over-read instances are present in mbstring regular expression functions when supplied with invalid multibyte data. These occur in ext/mbstring/oniguruma/regcomp.c, ext/mbstring/oniguruma/regexec.c, ext/mbstring/oniguruma/regparse.c, ext/mbstring/oniguruma/enc/unicode.c, and ext/mbstring/oniguruma/src/utf32_be.c when a multibyte regular expression pattern contains invalid multibyte sequences.

    • Update to 7.2.15-0ubuntu0.18.04.1
    Published Updated
  4. CVE-2019-9022

    High · CVSS 7.5EPSS 4.19%Fix available

    CVE-2019-9022

    An issue was discovered in PHP 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.2. dns_get_record misparses a DNS response, which can allow a hostile DNS server to cause PHP to misuse memcpy, leading to read operations going past the buffer allocated for DNS data. This affects php_parserr in ext/standard/dns.c for DNS_CAA and DNS_ANY queries.

    • Update to 7.2.15-0ubuntu0.18.04.1
    Published Updated
  5. CVE-2019-9021

    Critical · CVSS 9.8EPSS 10.06%Fix available

    CVE-2019-9021

    An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A heap-based buffer over-read in PHAR reading functions in the PHAR extension may allow an attacker to read allocated or unallocated memory past the actual data when trying to parse the file name, a different vulnerability than CVE-2018-20783. This is related to phar_detect_phar_fname_ext in ext/phar/phar.c.

    • Update to 7.2.15-0ubuntu0.18.04.1
    Published Updated
  6. CVE-2019-9020

    Critical · CVSS 9.8EPSS 10.06%Fix available

    CVE-2019-9020

    An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. Invalid input to the function xmlrpc_decode() can lead to an invalid memory access (heap out of bounds read or read after free). This is related to xml_elem_parse_buf in ext/xmlrpc/libxmlrpc/xml_element.c.

    • Update to 7.2.15-0ubuntu0.18.04.1
    Published Updated
  7. CVE-2018-20783

    High · CVSS 7.5EPSS 5.66%Fix available

    CVE-2018-20783

    In PHP before 5.6.39, 7.x before 7.0.33, 7.1.x before 7.1.25, and 7.2.x before 7.2.13, a buffer over-read in PHAR reading functions may allow an attacker to read allocated or unallocated memory past the actual data when trying to parse a .phar file. This is related to phar_parse_pharfile in ext/phar/phar.c.

    • Update to 7.2.15-0ubuntu0.18.04.1
    Published Updated
  8. CVE-2018-19518

    High · CVSS 7.5EPSS 96.11%Public exploitFix available

    CVE-2018-19518

    University of Washington IMAP Toolkit 2007f on UNIX, as used in imap_open() in PHP and other products, launches an rsh command (by means of the imap_rimap function in c-client/imap4r1.c and the tcp_aopen function in osdep/unix/tcp_unix.c) without preventing argument injection, which might allow remote attackers to execute arbitrary OS commands if the IMAP server name is untrusted input (e.g., entered by a user of a web application) and if rsh has been replaced by a program with different argument semantics. For example, if rsh is a link to ssh (as seen on Debian and Ubuntu systems), then the attack can use an IMAP server name containing a "-o

    • Update to 7.2.15-0ubuntu0.18.04.1
    Published Updated
  9. CVE-2018-17082

    Medium · CVSS 6.1EPSS 4.1%Public exploitFix available

    CVE-2018-17082

    The Apache2 component in PHP before 5.6.38, 7.0.x before 7.0.32, 7.1.x before 7.1.22, and 7.2.x before 7.2.10 allows XSS via the body of a "Transfer-Encoding: chunked" request, because the bucket brigade is mishandled in the php_handler function in sapi/apache2handler/sapi_apache2.c.

    • Update to 7.2.10-0ubuntu0.18.04.1
    Published Updated
  10. CVE-2018-12882

    Critical · CVSS 9.8EPSS 6.71%Fix available

    CVE-2018-12882

    exif_read_from_impl in ext/exif/exif.c in PHP 7.2.x through 7.2.7 allows attackers to trigger a use-after-free (in exif_read_from_file) because it closes a stream that it is not responsible for closing. The vulnerable code is reachable through the PHP exif_read_data function.

    • Update to 7.2.7-0ubuntu0.18.04.2
    Published Updated
  11. CVE-2018-10549

    High · CVSS 8.8EPSS 6.89%Fix available

    CVE-2018-10549

    An issue was discovered in PHP before 5.6.36, 7.0.x before 7.0.30, 7.1.x before 7.1.17, and 7.2.x before 7.2.5. exif_read_data in ext/exif/exif.c has an out-of-bounds read for crafted JPEG data because exif_iif_add_value mishandles the case of a MakerNote that lacks a final '\0' character.

    • Update to 7.2.5-0ubuntu0.18.04.1
    Published Updated
  12. CVE-2018-10548

    High · CVSS 7.5EPSS 8.35%Fix available

    CVE-2018-10548

    An issue was discovered in PHP before 5.6.36, 7.0.x before 7.0.30, 7.1.x before 7.1.17, and 7.2.x before 7.2.5. ext/ldap/ldap.c allows remote LDAP servers to cause a denial of service (NULL pointer dereference and application crash) because of mishandling of the ldap_get_dn return value.

    • Update to 7.2.5-0ubuntu0.18.04.1
    Published Updated
  13. CVE-2018-10547

    Medium · CVSS 6.1EPSS 3.44%Fix available

    CVE-2018-10547

    An issue was discovered in ext/phar/phar_object.c in PHP before 5.6.36, 7.0.x before 7.0.30, 7.1.x before 7.1.17, and 7.2.x before 7.2.5. There is Reflected XSS on the PHAR 403 and 404 error pages via request data of a request for a .phar file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2018-5712.

    • Update to 7.2.5-0ubuntu0.18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →