p PatchFirst

PatchFirst · Latest vulnerabilities

sudo vulnerabilities

Vulnerabilities published for sudo in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2023-22809

    High · CVSS 7.8EPSS 55.37%Public exploitFix available

    CVE-2023-22809

    In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to append arbitrary entries to the list of files to process. This can lead to privilege escalation. Affected versions are 1.8.0 through 1.9.12.p1. The problem exists because a user-specified editor may contain a "--" argument that defeats a protection mechanism, e.g., an EDITOR='vim -- /path/to/extra/file' value.

    • Update to 1.8.21p2-3ubuntu1.5
    Published Updated
  2. CVE-2019-18634

    High · CVSS 7.8EPSS 19.28%Public exploitFix available

    CVE-2019-18634

    In Sudo before 1.8.26, if pwfeedback is enabled in /etc/sudoers, users can trigger a stack-based buffer overflow in the privileged sudo process. (pwfeedback is a default setting in Linux Mint and elementary OS; however, it is NOT the default for upstream and many other packages, and would exist only if enabled by an administrator.) The attacker needs to deliver a long string to the stdin of getln() in tgetpass.c.

    • Update to 1.8.21p2-3ubuntu1.2
    Published Updated
  3. CVE-2019-14287

    High · CVSS 8.8EPSS 63.76%Public exploitFix available

    CVE-2019-14287

    In Sudo before 1.8.28, an attacker with access to a Runas ALL sudoer account can bypass certain policy blacklists and session PAM modules, and can cause incorrect logging, by invoking sudo with a crafted user ID. For example, this allows bypass of !root configuration, and USER= logging, for a "sudo -u \#$((0xffffffff))" command.

    • Update to 1.8.21p2-3ubuntu1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →