p PatchFirst

PatchFirst · Latest vulnerabilities

wireshark vulnerabilities · Page 11

Vulnerabilities published for wireshark in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 215

  1. CVE-2015-2188

    Not ratedEPSS 4.39%Fix available

    CVE-2015-2188

    epan/dissectors/packet-wcp.c in the WCP dissector in Wireshark 1.10.x before 1.10.13 and 1.12.x before 1.12.4 does not properly initialize a data structure, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet that is improperly handled during decompression.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  2. CVE-2015-0564

    Not ratedEPSS 2.78%Fix available

    CVE-2015-0564

    Buffer underflow in the ssl_decrypt_record function in epan/dissectors/packet-ssl-utils.c in Wireshark 1.10.x before 1.10.12 and 1.12.x before 1.12.3 allows remote attackers to cause a denial of service (application crash) via a crafted packet that is improperly handled during decryption of an SSL session.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  3. CVE-2015-0563

    Not ratedEPSS 2.44%Fix available

    CVE-2015-0563

    epan/dissectors/packet-smtp.c in the SMTP dissector in Wireshark 1.10.x before 1.10.12 and 1.12.x before 1.12.3 uses an incorrect length value for certain string-append operations, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  4. CVE-2015-0562

    Not ratedEPSS 2.65%Fix available

    CVE-2015-0562

    Multiple use-after-free vulnerabilities in epan/dissectors/packet-dec-dnart.c in the DEC DNA Routing Protocol dissector in Wireshark 1.10.x before 1.10.12 and 1.12.x before 1.12.3 allow remote attackers to cause a denial of service (application crash) via a crafted packet, related to the use of packet-scope memory instead of pinfo-scope memory.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  5. CVE-2015-0560

    Not ratedEPSS 1.58%Fix available

    CVE-2015-0560

    The dissect_wccp2r1_address_table_info function in epan/dissectors/packet-wccp.c in the WCCP dissector in Wireshark 1.10.x before 1.10.12 and 1.12.x before 1.12.3 does not initialize certain data structures, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  6. CVE-2015-0559

    Not ratedEPSS 1.58%Fix available

    CVE-2015-0559

    Multiple use-after-free vulnerabilities in epan/dissectors/packet-wccp.c in the WCCP dissector in Wireshark 1.10.x before 1.10.12 and 1.12.x before 1.12.3 allow remote attackers to cause a denial of service (application crash) via a crafted packet, related to the use of packet-scope memory instead of pinfo-scope memory.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  7. CVE-2014-8713

    Not ratedEPSS 3.79%Fix available

    CVE-2014-8713

    Stack-based buffer overflow in the build_expert_data function in epan/dissectors/packet-ncp2222.inc in the NCP dissector in Wireshark 1.10.x before 1.10.11 and 1.12.x before 1.12.2 allows remote attackers to cause a denial of service (application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  8. CVE-2014-8712

    Not ratedEPSS 3.1%Fix available

    CVE-2014-8712

    The build_expert_data function in epan/dissectors/packet-ncp2222.inc in the NCP dissector in Wireshark 1.10.x before 1.10.11 and 1.12.x before 1.12.2 does not properly initialize a data structure, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  9. CVE-2014-4020

    Not ratedEPSS 1.41%Fix available

    CVE-2014-4020

    The dissect_frame function in epan/dissectors/packet-frame.c in the frame metadissector in Wireshark 1.10.x before 1.10.8 interprets a negative integer as a length value even though it was intended to represent an error condition, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →