p PatchFirst

PatchFirst · Latest vulnerabilities

wireshark vulnerabilities · Page 8

Vulnerabilities published for wireshark in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 215

  1. CVE-2016-6512

    Medium · CVSS 5.9EPSS 7.6%Public exploitFix available

    CVE-2016-6512

    epan/dissectors/packet-wap.c in Wireshark 2.x before 2.0.5 omits an overflow check in the tvb_get_guintvar function, which allows remote attackers to cause a denial of service (infinite loop) via a crafted packet, related to the MMSE, WAP, WBXML, and WSP dissectors.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  2. CVE-2016-4421

    Medium · CVSS 5.9EPSS 1.34%Fix available

    CVE-2016-4421

    epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (deep recursion, stack consumption, and application crash) via a packet that specifies deeply nested data.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  3. CVE-2016-4417

    Medium · CVSS 5.9EPSS 1.37%Fix available

    CVE-2016-4417

    Off-by-one error in epan/dissectors/packet-gsm_abis_oml.c in the GSM A-bis OML dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers a 0xff tag value.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  4. CVE-2016-4084

    Medium · CVSS 5.9EPSS 2.14%Fix available

    CVE-2016-4084

    Integer signedness error in epan/dissectors/packet-mswsp.c in the MS-WSP dissector in Wireshark 2.0.x before 2.0.3 allows remote attackers to cause a denial of service (integer overflow and application crash) via a crafted packet that triggers an unexpected array size.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  5. CVE-2016-4078

    Medium · CVSS 5.9EPSS 2.12%Fix available

    CVE-2016-4078

    The IEEE 802.11 dissector in Wireshark 1.12.x before 1.12.11 and 2.0.x before 2.0.3 does not properly restrict element lists, which allows remote attackers to cause a denial of service (deep recursion and application crash) via a crafted packet, related to epan/dissectors/packet-capwap.c and epan/dissectors/packet-ieee80211.c.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  6. CVE-2016-2529

    Medium · CVSS 5.5EPSS 1.23%Fix available

    CVE-2016-2529

    The iseries_check_file_type function in wiretap/iseries.c in the iSeries file parser in Wireshark 2.0.x before 2.0.2 does not consider that a line may lack the "OBJECT PROTOCOL" substring, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted file.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  7. CVE-2016-2528

    Medium · CVSS 5.9EPSS 2.21%Fix available

    CVE-2016-2528

    The dissect_nhdr_extopt function in epan/dissectors/packet-lbmc.c in the LBMC dissector in Wireshark 2.0.x before 2.0.2 does not validate length values, which allows remote attackers to cause a denial of service (stack-based buffer overflow and application crash) via a crafted packet.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated
  8. CVE-2016-2527

    Medium · CVSS 5.5EPSS 1.43%Fix available

    CVE-2016-2527

    wiretap/nettrace_3gpp_32_423.c in the 3GPP TS 32.423 Trace file parser in Wireshark 2.0.x before 2.0.2 does not ensure that a '\0' character is present at the end of certain strings, which allows remote attackers to cause a denial of service (stack-based buffer overflow and application crash) via a crafted file.

    • Update to 2.6.3-1~ubuntu18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →