p PatchFirst

PatchFirst · Latest vulnerabilities

cups-filters vulnerabilities

Vulnerabilities published for cups-filters in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2024-47850

    High · CVSS 7.5EPSS 0.85%Fix available

    CVE-2024-47850

    CUPS cups-browsed before 2.5b1 will send an HTTP POST request to an arbitrary destination and port in response to a single IPP UDP packet requesting a printer to be added, a different vulnerability than CVE-2024-47176. (The request is meant to probe the new printer but can be used to create DDoS amplification attacks.)

    • Update to 1.27.4-1ubuntu0.3
    Published Updated
  2. CVE-2024-47076

    High · CVSS 8.6EPSS 79.9%Public exploitFix available

    libcupsfilters's cfGetPrinterAttributes5 does not validate IPP attributes returned from an IPP server

    CUPS is a standards-based, open-source printing system, and `libcupsfilters` contains the code of the filters of the former `cups-filters` package as library functions to be used for the data format conversion tasks needed in Printer Applications. The `cfGetPrinterAttributes5` function in `libcupsfilters` does not sanitize IPP attributes returned from an IPP server. When these IPP attributes are used, for instance, to generate a PPD file, this can lead to attacker controlled data to be provided to the rest of the CUPS system.

    • Update to 1.27.4-1ubuntu0.4
    Published Updated
  3. CVE-2024-47176

    Medium · CVSS 5.3EPSS 50.6%Public exploitFix available

    cups-browsed binds to `INADDR_ANY:631`, trusting any packet from any source

    CUPS is a standards-based, open-source printing system, and `cups-browsed` contains network printing functionality including, but not limited to, auto-discovering print services and shared printers. `cups-browsed` binds to `INADDR_ANY:631`, causing it to trust any packet from any source, and can cause the `Get-Printer-Attributes` IPP request to an attacker controlled URL. When combined with other vulnerabilities, such as CVE-2024-47076, CVE-2024-47175, and CVE-2024-47177, an attacker can execute arbitrary commands remotely on the target machine without authentication when a malicious printer is printed to.

    • Update to 1.27.4-1ubuntu0.4
    Published Updated
  4. CVE-2023-24805

    High · CVSS 8.8EPSS 3.7%Fix available

    Command injection in cups-filters

    cups-filters contains backends, filters, and other software required to get the cups printing service working on operating systems other than macos. If you use the Backend Error Handler (beh) to create an accessible network printer, this security vulnerability can cause remote code execution. `beh.c` contains the line `retval = system(cmdline) >> 8;` which calls the `system` command with the operand `cmdline`. `cmdline` contains multiple user controlled, unsanitized values. As a result an attacker with network access to the hosted print server can exploit this vulnerability to inject system commands which are executed in the context of the ru

    • Update to 1.27.4-1ubuntu0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →