p PatchFirst

PatchFirst · Latest vulnerabilities

poppler vulnerabilities

Vulnerabilities published for poppler in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2022-37050

    Medium · CVSS 6.5EPSS 1.08%Fix available

    CVE-2022-37050

    In Poppler 22.07.0, PDFDoc::savePageAs in PDFDoc.c callows attackers to cause a denial-of-service (application crashes with SIGABRT) by crafting a PDF file in which the xref data structure is mishandled in getCatalog processing. Note that this vulnerability is caused by the incomplete patch of CVE-2018-20662.

    • Update to 0.86.1-0ubuntu1.4
    Published Updated
  2. CVE-2022-38784

    High · CVSS 7.8EPSS 0.63%Fix available

    CVE-2022-38784

    Poppler prior to and including 22.08.0 contains an integer overflow in the JBIG2 decoder (JBIG2Stream::readTextRegionSeg() in JBIGStream.cc). Processing a specially crafted PDF file or JBIG2 image could lead to a crash or the execution of arbitrary code. This is similar to the vulnerability described by CVE-2022-38171 in Xpdf.

    • Update to 0.86.1-0ubuntu1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →