p PatchFirst

PatchFirst · Latest vulnerabilities

protobuf vulnerabilities

Vulnerabilities published for protobuf in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2022-1941

    High · CVSS 7.5EPSS 1.51%Fix available

    Out of Memory issue in ProtocolBuffers for cpp and python

    A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17

    • Update to 3.6.1.3-2ubuntu5.2
    Published Updated
  2. CVE-2021-22570

    Medium · CVSS 6.5EPSS 2.66%Fix available

    Nullptr Dereference in Protobuf

    Nullptr dereference when a null char is present in a proto symbol. The symbol is parsed incorrectly, leading to an unchecked call into the proto file's name during generation of the resulting error message. Since the symbol is incorrectly parsed, the file is nullptr. We recommend upgrading to version 3.15.0 or greater.

    • Update to 3.6.1.3-2ubuntu5.2
    Published Updated
  3. CVE-2021-22569

    High · CVSS 7.5EPSS 1.8%Fix available

    Denial of Service of protobuf-java parsing procedure

    An issue in protobuf-java allowed the interleaving of com.google.protobuf.UnknownFieldSet fields in such a way that would be processed out of order. A small malicious payload can occupy the parser for several minutes by creating large numbers of short-lived objects that cause frequent, repeated pauses. We recommend upgrading libraries beyond the vulnerable versions.

    • Update to 3.6.1.3-2ubuntu5.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →