p PatchFirst

PatchFirst · Latest vulnerabilities

util-linux vulnerabilities

Vulnerabilities published for util-linux in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2024-28085

    Low · CVSS 3.3EPSS 2.24%Public exploitFix available

    CVE-2024-28085

    wall in util-linux through 2.40, often installed with setgid tty permissions, allows escape sequences to be sent to other users' terminals through argv. (Specifically, escape sequences received from stdin are blocked, but escape sequences received from argv are not blocked.) There may be plausible scenarios where this leads to account takeover.

    • Update to 2.34-0.1ubuntu9.6
    Published Updated
  2. CVE-2021-3996

    Medium · CVSS 5.5EPSS 0.64%Fix available

    CVE-2021-3996

    A logic error was found in the libmount library of util-linux in the function that allows an unprivileged user to unmount a FUSE filesystem. This flaw allows a local user on a vulnerable system to unmount other users' filesystems that are either world-writable themselves (like /tmp) or mounted in a world-writable directory. An attacker may use this flaw to cause a denial of service to applications that use the affected filesystems.

    • Update to 2.34-0.1ubuntu9.3
    Published Updated
  3. CVE-2021-3995

    Medium · CVSS 5.5EPSS 0.64%Fix available

    CVE-2021-3995

    A logic error was found in the libmount library of util-linux in the function that allows an unprivileged user to unmount a FUSE filesystem. This flaw allows an unprivileged local attacker to unmount FUSE filesystems that belong to certain other users who have a UID that is a prefix of the UID of the attacker in its string form. An attacker may use this flaw to cause a denial of service to applications that use the affected filesystems.

    • Update to 2.34-0.1ubuntu9.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →