p PatchFirst

PatchFirst · Latest vulnerabilities

xz-utils vulnerabilities

Vulnerability published for xz-utils in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. USN-8945-1

    Not ratedFix available

    xz-utils vulnerability

    It was discovered that XZ Utils incorrectly handled certain memory allocation failures when reinitializing decoders for specific compressed file formats. An attacker could possibly use this issue to trigger an invalid memory write, resulting in a denial of service or arbitrary code execution.

    • Update to 5.2.5-2ubuntu1.2
    Published Updated
  2. CVE-2026-34743

    Low · CVSS 1.7EPSS 0.51%Fix available

    XZ Utils: Buffer overflow in lzma_index_append()

    XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.

    • Update to 5.2.5-2ubuntu1.1
    Published Updated
  3. CVE-2022-1271

    High · CVSS 8.8EPSS 5.55%Fix available

    CVE-2022-1271

    An arbitrary file write vulnerability was found in GNU gzip's zgrep utility. When zgrep is applied on the attacker's chosen file name (for example, a crafted file name), this can overwrite an attacker's content to an arbitrary attacker-selected file. This flaw occurs due to insufficient validation when processing filenames with two or more newlines where selected content and the target file names are embedded in crafted multi-line file names. This flaw allows a remote, low privileged attacker to force zgrep to write arbitrary files on the system.

    • Update to 5.2.5-2ubuntu1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →