p PatchFirst

PatchFirst · Latest vulnerabilities

krb5 vulnerabilities

Vulnerabilities published for krb5 in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2026-107778

    High · CVSS 7.1EPSS 0.42%No fix published

    MIT krb5 through 1.22.2 NULL Pointer Dereference via krb5_rd_cred()

    MIT Kerberos 5 (krb5) through 1.22.2 contains a NULL pointer dereference in make_cred_list() in rd_cred.c that allows authenticated Kerberos clients to crash services by sending mismatched KRB-CRED arrays. Attackers can send forwarded credentials with more tickets than ticket_info entries through gss_accept_sec_context() to crash GSS-API acceptor services, causing denial of service.

    Published Updated
  2. CVE-2026-107708

    Medium · CVSS 6.9EPSS 0.52%No fix published

    MIT krb5 through 1.22.2 KDC NULL Pointer Dereference via S4U2Proxy PAC

    MIT krb5 through 1.22.2 contains a NULL pointer dereference vulnerability in the KDC's get_pac_princ_with_realm() that returns success while leaving the client principal NULL on malformed names. A malicious or compromised cross-realm trusted KDC can send an S4U2Proxy request with a PAC carrying a malformed client name to crash krb5kdc and deny authentication.

    Published Updated
  3. CVE-2026-11850

    Medium · CVSS 5EPSS 0.27%Fix available

    Krb5: krb5: integer underflow in berval2tl_data() leads to heap out-of-bounds read

    An integer underflow vulnerability was found in MIT krb5 in the berval2tl_data() function in plugins/kdb/ldap/libkdb_ldap/ldap_principal2.c. The function performs an unsigned subtraction (bv_len - 2) without a prior bounds check. When bv_len is 0 or 1, the subtraction wraps to a large value which is then truncated to uint16_t, yielding 0xFFFE (65534) or 0xFFFF (65535). The subsequent malloc succeeds and memcpy reads up to 65534 bytes from a 0-1 byte buffer, resulting in a heap out-of-bounds read. The attack vector involves a malicious or compromised LDAP KDB backend returning a krbExtraData attribute with bv_len < 2, triggering the underflow

    • Update to 1.20.1-6ubuntu2.7
    Published Updated
  4. CVE-2026-40356

    Medium · CVSS 5.9EPSS 0.6%Fix available

    CVE-2026-40356

    In MIT Kerberos 5 (aka krb5) before 1.22.3, there is an integer underflow and resultant out-of-bounds read if an application calls gss_accept_sec_context() on a system with a NegoEx mechanism registered in /etc/gss/mech. An unauthenticated remote attacker can trigger this, possibly causing the process to terminate in parse_message.

    • Update to 1.20.1-6ubuntu2.7
    Published Updated
  5. CVE-2026-40355

    Medium · CVSS 5.9EPSS 0.65%Fix available

    CVE-2026-40355

    In MIT Kerberos 5 (aka krb5) before 1.22.3, there is a NULL pointer dereference if an application calls gss_accept_sec_context() on a system with a NegoEx mechanism registered in /etc/gss/mech. An unauthenticated remote attacker can trigger this, causing the process to terminate in parse_nego_message.

    • Update to 1.20.1-6ubuntu2.7
    Published Updated
  6. CVE-2025-3576

    Medium · CVSS 5.9EPSS 0.35%Fix available

    Krb5: kerberos rc4-hmac-md5 checksum vulnerability enabling message spoofing via md5 collisions

    A vulnerability in the MIT Kerberos implementation allows GSSAPI-protected messages using RC4-HMAC-MD5 to be spoofed due to weaknesses in the MD5 checksum design. If RC4 is preferred over stronger encryption types, an attacker could exploit MD5 collisions to forge message integrity codes. This may lead to unauthorized message tampering.

    • Update to 1.20.1-6ubuntu2.6
    Published Updated
  7. CVE-2024-3596

    Critical · CVSS 9EPSS 14.86%Fix available

    RADIUS Protocol under RFC2865 is vulnerable to forgery attacks.

    RADIUS Protocol under RFC 2865 is susceptible to forgery attacks by a local attacker who can modify any valid Response (Access-Accept, Access-Reject, or Access-Challenge) to any other response using a chosen-prefix collision attack against MD5 Response Authenticator signature.

    • Update to 1.20.1-6ubuntu2.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →