p PatchFirst

PatchFirst · Latest vulnerabilities

wpa vulnerabilities

Vulnerability published for wpa in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2026-49878

    High · CVSS 7.2EPSS 0.29%No fix published

    CVE-2026-49878

    In wpas_handle_robust_av_scs_recv_action of robust_av.c, there is a possible out-of-bounds write due to a logic error in the code. This could lead to remote code execution with System execution privileges needed. User interaction is not needed for exploitation.

    Published Updated
  2. CVE-2026-78807

    High · CVSS 7.1EPSS 0.08%No fix published

    CVE-2026-78807

    An issue in wpa_supplicant all versions before v.2.12 allows a local attacker to bypass proper network context and AKMP matching for PMKSA caching via missing validation in the driver based PMKSA selection path in wpa.c

    Published Updated
  3. CVE-2022-37660

    Medium · CVSS 6.5EPSS 0.38%Fix available

    CVE-2022-37660

    In hostapd 2.10 and earlier, the PKEX code remains active even after a successful PKEX association. An attacker that successfully bootstrapped public keys with another entity using PKEX in the past, will be able to subvert a future bootstrapping by passively observing public keys, re-using the encrypting element Qi and subtracting it from the captured message M (X = M - Qi). This will result in the public ephemeral key X; the only element required to subvert the PKEX association.

    • Update to 2:2.10-21ubuntu0.2
    Published Updated
  4. CVE-2024-5290

    High · CVSS 8.8EPSS 0.65%Fix available

    CVE-2024-5290

    An issue was discovered in Ubuntu wpa_supplicant that resulted in loading of arbitrary shared objects, which allows a local unprivileged attacker to escalate privileges to the user that wpa_supplicant runs as (usually root). Membership in the netdev group or access to the dbus interface of wpa_supplicant allow an unprivileged user to specify an arbitrary path to a module to be loaded by the wpa_supplicant process; other escalation paths might exist.

    • Update to 2:2.10-21ubuntu0.1
    Published Updated
  5. CVE-2023-52160

    Medium · CVSS 6.5EPSS 1.18%No fix published

    CVE-2023-52160

    The implementation of PEAP in wpa_supplicant through 2.10 allows authentication bypass. For a successful attack, wpa_supplicant must be configured to not verify the network's TLS certificate during Phase 1 authentication, and an eap_peap_decrypt vulnerability can then be abused to skip Phase 2 authentication. The attack vector is sending an EAP-TLV Success packet instead of starting Phase 2. This allows an adversary to impersonate Enterprise Wi-Fi networks.

    Published Updated
  6. CVE-2019-5062

    High · CVSS 7.4EPSS 0.57%No fix published

    CVE-2019-5062

    An exploitable denial-of-service vulnerability exists in the 802.11w security state handling for hostapd 2.6 connected clients with valid 802.11w sessions. By simulating an incomplete new association, an attacker can trigger a deauthentication against stations using 802.11w, resulting in a denial of service.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →