p PatchFirst

PatchFirst · Latest vulnerabilities

adminer vulnerabilities

Vulnerabilities published for adminer in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-25892

    High · CVSS 7.5EPSS 1.72%Public exploitNo fix published

    Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint

    Adminer is open-source database management software. Adminer v5.4.1 and earlier has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, openssl_verify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Upgrade to Adminer 5.4.2.

    Published Updated
  2. CVE-2025-43960

    High · CVSS 8.6EPSS 0.73%No fix published

    CVE-2025-43960

    Adminer 4.8.1, when using Monolog for logging, allows a Denial of Service (memory consumption) via a crafted serialized payload (e.g., using s:1000000000), leading to a PHP Object Injection issue. Remote, unauthenticated attackers can trigger this by sending a malicious serialized object, which forces excessive memory usage, rendering Adminer’s interface unresponsive and causing a server-level DoS. While the server may recover after several minutes, multiple simultaneous requests can cause a complete crash requiring manual intervention.

    Published Updated
  3. CVE-2023-45195

    Medium · CVSS 6.9EPSS 0.41%No fix published

    Adminer and AdminerEvo SSRF

    Adminer and AdminerEvo are vulnerable to SSRF via database connection fields. This could allow an unauthenticated remote attacker to enumerate or access systems the attacker would not otherwise have access to. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →