p PatchFirst

PatchFirst · Latest vulnerabilities

cups-filters vulnerabilities

Vulnerabilities published for cups-filters in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-64524

    Low · CVSS 3.3EPSS 0.22%Fix available

    CUPS rastertopclx Filter Vulnerable to Heap Buffer Overflow Leading to Potential Arbitrary Code Execution

    cups-filters contains backends, filters, and other software required to get the cups printing service working on operating systems other than macos. In versions 2.0.1 and prior, a heap-buffer-overflow vulnerability in the rastertopclx filter causes the program to crash with a segmentation fault when processing maliciously crafted input data. This issue can be exploited to trigger memory corruption, potentially leading to arbitrary code execution. This issue has been patched via commit 956283c.

    • Update to 2.0.1-0ubuntu3.25.10.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →