CVE-2026-41989
Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.
- Update to 1.11.0-7ubuntu0.1
Published Updated
PatchFirst · Latest vulnerabilities
Vulnerabilities published for libgcrypt20 in the last 30 days: 0. Listed in the KEV catalogue: 0.
Vulnerabilities: 2
Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.
A timing-based side-channel flaw was found in libgcrypt's RSA implementation. This issue may allow a remote attacker to initiate a Bleichenbacher-style attack, which can lead to the decryption of RSA ciphertexts.
Check your installed stack and versions against the current vulnerability feeds.