p PatchFirst

PatchFirst · Latest vulnerabilities

trafficserver vulnerabilities

Vulnerabilities published for trafficserver in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 11

  1. CVE-2025-65114

    High · CVSS 7.5EPSS 0.43%No fix published

    Apache Traffic Server: Malformed chunked message body allows request smuggling

    Apache Traffic Server allows request smuggling if chunked messages are malformed.  This issue affects Apache Traffic Server: from 9.0.0 through 9.2.12, from 10.0.0 through 10.1.1. Users are recommended to upgrade to version 9.2.13 or 10.1.2, which fix the issue.

    Published Updated
  2. CVE-2025-58136

    High · CVSS 7.5EPSS 0.67%No fix published

    Apache Traffic Server: A simple legitimate POST request causes a crash

    A bug in POST request handling causes a crash under a certain condition. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.1, from 9.0.0 through 9.2.12. Users are recommended to upgrade to version 10.1.2 or 9.2.13, which fix the issue. A workaround for older versions is to set proxy.config.http.request_buffer_enabled to 0 (the default value is 0).

    Published Updated
  3. CVE-2025-31698

    High · CVSS 7.5EPSS 0.55%No fix published

    Apache Traffic Server: Client IP address from PROXY protocol is not used for ACL

    ACL configured in ip_allow.config or remap.config does not use IP addresses that are provided by PROXY protocol. Users can use a new setting (proxy.config.acl.subjects) to choose which IP addresses to use for the ACL if Apache Traffic Server is configured to accept PROXY protocol.  This issue affects undefined: from 10.0.0 through 10.0.6, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.

    Published Updated
  4. CVE-2025-49763

    High · CVSS 7.5EPSS 0.74%No fix published

    Apache Traffic Server: Remote DoS via memory exhaustion in ESI Plugin

    ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.

    Published Updated
  5. CVE-2024-53868

    High · CVSS 7.5EPSS 0.67%No fix published

    Apache Traffic Server: Malformed chunked message body allows request smuggling

    Apache Traffic Server allows request smuggling if chunked messages are malformed.  This issue affects Apache Traffic Server: from 9.2.0 through 9.2.9, from 10.0.0 through 10.0.4. Users are recommended to upgrade to version 9.2.10 or 10.0.5, which fixes the issue.

    Published Updated
  6. CVE-2024-38311

    Medium · CVSS 6.3EPSS 0.91%No fix published

    Apache Traffic Server: Request smuggling via pipelining after a chunked message body

    Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 9.2.9 or 10.0.4, which fixes the issue.

    Published Updated
  7. CVE-2024-56195

    Medium · CVSS 6.3EPSS 0.78%No fix published

    Apache Traffic Server: Intercept plugins are not access controlled

    Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.2.0 through 9.2.8, from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 9.2.9 or 10.0.4, which fixes the issue.

    Published Updated
  8. CVE-2024-56202

    Medium · CVSS 4.3EPSS 0.87%No fix published

    Apache Traffic Server: Expect header field can unreasonably retain resource

    Expected Behavior Violation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3. Users are recommended to upgrade to versions 9.2.9 or 10.0.4 or newer, which fixes the issue.

    Published Updated
  9. CVE-2024-50306

    Critical · CVSS 9.1EPSS 1.57%No fix published

    Apache Traffic Server: Server process can fail to drop privilege

    Unchecked return value can allow Apache Traffic Server to retain privileges on startup. This issue affects Apache Traffic Server: from 9.2.0 through 9.2.5, from 10.0.0 through 10.0.1. Users are recommended to upgrade to version 9.2.6 or 10.0.2, which fixes the issue.

    Published Updated
  10. CVE-2024-50305

    High · CVSS 7.5EPSS 0.93%Fix available

    Apache Traffic Server: Valid Host field value can cause crashes

    Valid Host header field can cause Apache Traffic Server to crash on some platforms. This issue affects Apache Traffic Server: from 9.2.0 through 9.2.5. Users are recommended to upgrade to version 9.2.6, which fixes the issue, or 10.0.2, which does not have the issue.

    • Update to 9.2.5+ds-1ubuntu2.1
    Published Updated
  11. CVE-2024-38479

    High · CVSS 7.5EPSS 0.82%No fix published

    Apache Traffic Server: Cache key plugin is vulnerable to cache poisoning attack

    Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.5. Users are recommended to upgrade to version 9.2.6, which fixes the issue, or 10.0.2, which does not have the issue.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →