p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-101258

    High · CVSS 7.8EPSS 0.18%Fix available

    Ghostscript: ghostscript: -dsafer sandbox bypass via type 5 shading oob write and procedure-stream use-after-free

    A flaw was found in Ghostscript. When Ghostscript renders a crafted PostScript or EPS document, it can bypass the -dSAFER sandbox and execute arbitrary shell commands in the context of the Ghostscript process. The issue chains memory corruption in document parsing with disabling of internal path access controls at runtime. An attacker can deliver the document directly or through formats that delegate rendering to Ghostscript (for example EPS import or print conversion workflows). Successful exploitation can compromise confidentiality, integrity, and availability of data accessible to the process running Ghostscript.

    • Update to 10.07.1~dfsg-1ubuntu2.1
    Published Updated
  2. CVE-2026-103226

    Medium · CVSS 5.3EPSS 0.32%Fix available

    Artifex Ghostscript Pdfwrite gdevpsfx.c type1_callsubr stack-based overflow

    A vulnerability was identified in Artifex Ghostscript up to 10.07.0. Affected is the function type1_callsubr of the file devices/vector/gdevpsfx.c of the component Pdfwrite. The manipulation leads to stack-based buffer overflow. Remote exploitation of the attack is possible. The exploit is publicly available and might be used. Upgrading to version 10.08.0 is able to address this issue. It is suggested to upgrade the affected component. A solution was implemented: "I've chosen to fix this slightly differently by using the defined macro in the font parsing loop rather than in the callsubr function, because this better matches the pattern of 'no

    • Update to 10.07.1~dfsg-1ubuntu2.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →