p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 2

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 64

  1. CVE-2022-3128

    Medium · CVSS 4.8EPSS 0.7%No fix published

    Donation Thermometer < 2.1.3 - Admin+ Stored Cross-Site Scripting

    The Donation Thermometer WordPress plugin before 2.1.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

    Published Updated
  2. CVE-2022-3125

    High · CVSS 8.8EPSS 1.64%No fix published

    Frontend File Manager < 21.3 - Subscriber+ Arbitrary File Upload

    The Frontend File Manager Plugin WordPress plugin before 21.3 allows any authenticated users, such as subscriber, to rename a file to an arbitrary extension, like PHP, which could allow them to basically be able to upload arbitrary files on the server and achieve RCE

    Published Updated
  3. CVE-2022-3124

    Medium · CVSS 5.3EPSS 8.26%Public exploitNo fix published

    Frontend File Manager < 21.3 - Unauthenticated File Renaming

    The Frontend File Manager Plugin WordPress plugin before 21.3 allows any unauthenticated user to rename uploaded files from users. Furthermore, due to the lack of validation in the destination filename, this could allow allow them to change the content of arbitrary files on the web server

    Published Updated
  4. CVE-2022-2839

    Medium · CVSS 5.4EPSS 0.47%No fix published

    Zephyr Project Manager < 3.2.55 - Unauthorised AJAX Calls To Stored XSS

    The Zephyr Project Manager WordPress plugin before 3.2.55 does not have any authorisation as well as CSRF in all its AJAX actions, allowing unauthenticated users to call them either directly or via CSRF attacks. Furthermore, due to the lack of sanitisation and escaping, it could also allow them to perform Stored Cross-Site Scripting attacks against logged in admins.

    Published Updated
  5. CVE-2022-2763

    Medium · CVSS 4.8EPSS 0.75%No fix published

    WP Socializer < 7.3 - Admin+ Stored Cross-Site Scripting

    The WP Socializer WordPress plugin before 7.3 does not sanitise and escape some of its Icons settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

    Published Updated
  6. CVE-2022-2628

    Medium · CVSS 4.8EPSS 0.7%No fix published

    DSGVO All in one for WP < 4.2 - Admin+ Stored Cross-Site Scripting

    The DSGVO All in one for WP WordPress plugin before 4.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

    Published Updated
  7. CVE-2022-31129

    High · CVSS 7.5EPSS 5.55%No fix published

    Inefficient Regular Expression Complexity in moment

    moment is a JavaScript date library for parsing, validating, manipulating, and formatting dates. Affected versions of moment were found to use an inefficient parsing algorithm. Specifically using string-to-date parsing in moment (more specifically rfc2822 parsing, which is tried by default) has quadratic (N^2) complexity on specific inputs. Users may notice a noticeable slowdown is observed with inputs above 10k characters. Users who pass user-provided strings without sanity length checks to moment constructor are vulnerable to (Re)DoS attacks. The problem is patched in 2.29.4, the patch can be applied to all affected versions with minimal tw

    Published Updated
  8. CVE-2021-39203

    Medium · CVSS 6.8EPSS 0.94%No fix published

    Private data disclosure/privilege escalation through the block editor in Wordpress

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions authenticated users who don't have permission to view private post types/data can bypass restrictions in the block editor under certain conditions. This affected WordPress 5.8 beta during the testing period. It's fixed in the final 5.8 release.

    Published Updated
  9. CVE-2021-39202

    High · CVSS 7.6EPSS 0.82%No fix published

    WordPress 5.8 beta: Stored Cross-Site Scripting (XSS) vulnerability in widget

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions the widgets editor introduced in WordPress 5.8 beta 1 has improper handling of HTML input in the Custom HTML feature. This leads to stored XSS in the custom HTML widget. This has been patched in WordPress 5.8. It was only present during the testing/beta phase of WordPress 5.8.

    Published Updated
  10. CVE-2021-39201

    High · CVSS 7.6EPSS 1.49%No fix published

    Authenticated cross-site scripting (XSS) in WordPress editor

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/repo

    Published Updated
  11. CVE-2021-39200

    Medium · CVSS 5.3EPSS 1.97%No fix published

    Information Disclosure in wp_die() via JSONP in wordpress

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions output data of the function wp_die() can be leaked under certain conditions, which can include data like nonces. It can then be used to perform actions on your behalf. This has been patched in WordPress 5.8.1, along with any older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

    Published Updated
  12. CVE-2021-29450

    Medium · CVSS 6.5EPSS 2.09%No fix published

    WordPress Authenticated disclosure of password-protected posts and pages

    Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

    Published Updated
  13. CVE-2021-29447

    High · CVSS 7.1EPSS 85.72%Public exploitNo fix published

    WordPress Authenticated XXE attack when installation is running PHP 8

    Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →