p PatchFirst

PatchFirst · Latest vulnerabilities

libpng vulnerabilities

Vulnerabilities published for libpng in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2026-34757

    Medium · CVSS 5.1EPSS 0.19%Fix available

    LIBPNG has a yse-after-free in png_set_PLTE, png_set_tRNS and png_set_hIST leading to corrupted chunk data and potential heap information disclosure

    LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From 1.0.9 to before 1.6.57, passing a pointer obtained from png_get_PLTE, png_get_tRNS, or png_get_hIST back into the corresponding setter on the same png_struct/png_info pair causes the setter to read from freed memory and copy its contents into the replacement buffer. The setter frees the internal buffer before copying from the caller-supplied pointer, which now dangles. The freed region may contain stale data (producing silently corrupted chunk metadata) or data from subsequent heap allocations (leaki

    • Update to 1.2.50-1ubuntu2.14.04.3+esm2
    Published Updated
  2. CVE-2026-33416

    High · CVSS 7.5EPSS 1.07%Fix available

    LIBPNG has use-after-free via pointer aliasing in `png_set_tRNS` and `png_set_PLTE`

    LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. In versions 1.2.1 through 1.6.55, `png_set_tRNS` and `png_set_PLTE` each alias a heap-allocated buffer between `png_struct` and `png_info`, sharing a single allocation across two structs with independent lifetimes. The `trans_alpha` aliasing has been present since at least libpng 1.0, and the `palette` aliasing since at least 1.2.1. Both affect all prior release lines `png_set_tRNS` sets `png_ptr->trans_alpha = info_ptr->trans_alpha` (256-byte buffer) and `png_set_PLTE` sets `info_ptr->palette = png_ptr->

    • Update to 1.2.50-1ubuntu2.14.04.3+esm2
    Published Updated
  3. CVE-2026-3713

    Medium · CVSS 4.8EPSS 0.13%No fix published

    pnggroup libpng pnm2png pnm2png.c do_pnm2png heap-based overflow

    A flaw has been found in pnggroup libpng up to 1.6.55. Affected by this vulnerability is the function do_pnm2png of the file contrib/pngminus/pnm2png.c of the component pnm2png. This manipulation of the argument width/height causes heap-based buffer overflow. The attack is restricted to local execution. The exploit has been published and may be used. The project was informed of the problem early through an issue report but has not responded yet.

    Published Updated
  4. CVE-2026-25646

    High · CVSS 8.3EPSS 1.09%Fix available

    LIBPNG has a heap buffer overflow in png_set_quantize

    LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to 1.6.55, an out-of-bounds read vulnerability exists in the png_set_quantize() API function. When the function is called with no histogram and the number of colors in the palette is more than twice the maximum supported by the user's display, certain palettes will cause the function to enter into an infinite loop that reads past the end of an internal heap-allocated buffer. The images that trigger this vulnerability are valid per the PNG specification. This vulnerability is fixed in 1.6.55.

    • Update to 1.2.50-1ubuntu2.14.04.3+esm1
    Published Updated
  5. CVE-2025-64505

    Medium · CVSS 6.1EPSS 0.21%Fix available

    LIBPNG is vulnerable to a heap buffer overflow in `png_do_quantize` via malformed palette index

    LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to version 1.6.51, a heap buffer over-read vulnerability exists in libpng's png_do_quantize function when processing PNG files with malformed palette indices. The vulnerability occurs when palette_lookup array bounds are not validated against externally-supplied image data, allowing an attacker to craft a PNG file with out-of-range palette indices that trigger out-of-bounds memory access. This issue has been patched in version 1.6.51.

    • Update to 1.2.50-1ubuntu2.14.04.3+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →