p PatchFirst

PatchFirst · Latest vulnerabilities

zlib vulnerabilities

Vulnerabilities published for zlib in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2026-85091

    High · CVSS 8.3EPSS 0.47%No fix published

    zlib 1.3.1.2 through 1.3.2 Heap Buffer Overflow via gz_vacate

    zlib versions 1.3.1.2 through 1.3.2 contain a heap buffer overflow vulnerability in the gz_vacate() function when processing non-blocking gzwrite() operations with stale external buffer pointers. Attackers can trigger the overflow by calling gzprintf() or gzvprintf() after a write stall, causing an unchecked memmove() to write beyond the internal input buffer boundary.

    Published Updated
  2. CVE-2023-45853

    High · CVSS 8.8EPSS 3.45%Fix available

    CVE-2023-45853

    MiniZip in zlib through 1.3 has an integer overflow and resultant heap-based buffer overflow in zipOpenNewFileInZip4_64 via a long filename, comment, or extra field. NOTE: MiniZip is not a supported part of the zlib product. NOTE: pyminizip through 0.2.6 is also vulnerable because it bundles an affected zlib version, and exposes the applicable MiniZip code through its compress API.

    • Update to 1:1.2.8.dfsg-1ubuntu1.1+esm3
    Published Updated
  3. CVE-2022-37434

    Critical · CVSS 9.8EPSS 19.24%Fix available

    CVE-2022-37434

    zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g., see the nodejs/node reference).

    • Update to 1:1.2.8.dfsg-1ubuntu1.1+esm2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →