p PatchFirst

PatchFirst · Latest vulnerabilities

phpunit vulnerabilities

Vulnerabilities published for phpunit in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-41570

    High · CVSS 7.8EPSS 0.19%No fix published

    PHPUnit: Argument injection via newline in PHP INI values forwarded to child processes

    PHPUnit is a testing framework for PHP. In versions 12.5.21 and 13.1.5, PHPUnit forwards PHP INI settings to child processes (used for isolated/PHPT test execution) as -d name=value command-line arguments without neutralizing INI metacharacters. Because PHP's INI parser interprets " as a string delimiter, ; as the start of a comment, and most importantly a newline as a directive separator, a value containing a newline is parsed by the child process as multiple INI directives. An attacker able to influence a single INI value can therefore inject arbitrary additional directives into the child's configuration, including auto_prepend_file, extens

  2. CVE-2026-24765

    High · CVSS 7.8EPSS 0.38%No fix published

    PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling

    PHPUnit is a testing framework for PHP. A vulnerability has been discovered in versions prior to 12.5.8, 11.5.50, 10.5.62, 9.6.33, and 8.5.52 involving unsafe deserialization of code coverage data in PHPT test execution. The vulnerability exists in the `cleanupForCoverage()` method, which deserializes code coverage files without validation, potentially allowing remote code execution if malicious `.coverage` files are present prior to the execution of the PHPT test. The vulnerability occurs when a `.coverage` file, which should not exist before test execution, is deserialized without the `allowed_classes` parameter restriction. An attacker wit

    Published Updated
  3. CVE-2017-9841

    Critical · CVSS 9.8EPSS 100%In KEVPublic exploitFix available

    CVE-2017-9841

    Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP code via HTTP POST data beginning with a "<?php " substring, as demonstrated by an attack on a site with an exposed /vendor folder, i.e., external access to the /vendor/phpunit/phpunit/src/Util/PHP/eval-stdin.php URI.

    • Update to 5.1.3-1+ubuntu3+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →