p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 2

Vulnerabilities published for ghostscript in the last 30 days: 3. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 28

  1. CVE-2023-43115

    High · CVSS 8.8EPSS 5.96%No fix published

    CVE-2023-43115

    In Artifex Ghostscript through 10.01.2, gdevijs.c in GhostPDL can lead to remote code execution via crafted PostScript documents because they can switch to the IJS device, or change the IjsServer parameter, after SAFER has been activated. NOTE: it is a documented risk that the IJS server can be specified on a gs command line (the IJS device inherently must execute a command to start the IJS server).

    Published Updated
  2. CVE-2023-38559

    Medium · CVSS 5.5EPSS 0.43%Fix available

    Ghostscript: out-of-bound read in base/gdevdevn.c:1973 in devn_pcx_write_rle could result in dos

    A buffer overflow flaw was found in base/gdevdevn.c:1973 in devn_pcx_write_rle() in ghostscript. This issue may allow a local attacker to cause a denial of service via outputting a crafted PDF file for a DEVN device with gs.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.18+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →