p PatchFirst

PatchFirst · Latest vulnerabilities

inetutils vulnerabilities

Vulnerabilities published for inetutils in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 10

  1. CVE-2026-28372

    High · CVSS 7.4EPSS 0.41%Public exploitFix available

    CVE-2026-28372

    telnetd in GNU inetutils through 2.7 allows privilege escalation that can be exploited by abusing systemd service credentials support added to the login(1) implementation of util-linux in release 2.40. This is related to client control over the CREDENTIALS_DIRECTORY environment variable, and requires an unprivileged local user to create a login.noauth file.

    • Update to 2:1.9.4-3ubuntu0.1+esm5
    Published Updated
  2. CVE-2023-40303

    High · CVSS 7.8EPSS 0.41%Fix available

    CVE-2023-40303

    GNU inetutils before 2.5 may allow privilege escalation because of unchecked return values of set*id() family functions in ftpd, rcp, rlogin, rsh, rshd, and uucpd. This is, for example, relevant if the setuid system call fails when a process is trying to drop privileges before letting an ordinary user control the activities of the process.

    • Update to 2:1.9.4-3ubuntu0.1+esm2
    Published Updated
  3. CVE-2022-39028

    High · CVSS 7.5EPSS 2.35%Fix available

    CVE-2022-39028

    telnetd in GNU Inetutils through 2.3, MIT krb5-appl through 1.0.3, and derivative works has a NULL pointer dereference via 0xff 0xf7 or 0xff 0xf8. In a typical installation, the telnetd application would crash but the telnet service would remain available through inetd. However, if the telnetd application has many crashes within a short time interval, the telnet service would become unavailable after inetd logs a "telnet/tcp server failing (looping), service terminated" error. NOTE: MIT krb5-appl is not supported upstream but is shipped by a few Linux distributions. The affected code was removed from the supported MIT Kerberos 5 (aka krb5) pr

    • Update to 2:1.9.4-3ubuntu0.1+esm2
    Published Updated
  4. CVE-2019-0053

    High · CVSS 7.8EPSS 0.59%Fix available

    Junos OS: Insufficient validation of environment variables in telnet client may lead to stack-based buffer overflow

    Insufficient validation of environment variables in the telnet client supplied in Junos OS can lead to stack-based buffer overflows, which can be exploited to bypass veriexec restrictions on Junos OS. A stack-based overflow is present in the handling of environment variables when connecting via the telnet client to remote telnet servers. This issue only affects the telnet client — accessible from the CLI or shell — in Junos OS. Inbound telnet services are not affected by this issue. This issue affects: Juniper Networks Junos OS: 12.3 versions prior to 12.3R12-S13; 12.3X48 versions prior to 12.3X48-D80; 14.1X53 versions prior to 14.1X53-D130,

    • Update to 2:1.9.4-3ubuntu0.1+esm2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →