p PatchFirst

PatchFirst · Latest vulnerabilities

lxml vulnerabilities

Vulnerabilities published for lxml in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-49825

    High · CVSS 8.2EPSS 0.3%Fix available

    lxml: javascript: URL bypass in Cleaner via xlink:href

    lxml is a library for processing XML and HTML in the Python language. Prior to 6.1.1, link attributes in ``lxml.html.defs.link_attrs`` were missing ``xlink:href``, which can be used for URL bypass attacks in embedded SVG/MathML/etc. content. This vulnerability was fixed in lxml 6.1.1 and lxml_html_clean 0.4.5.

    • Update to 4.2.1-1ubuntu0.6+esm1
    Published Updated
  2. CVE-2026-41066

    High · CVSS 7.5EPSS 0.32%Fix available

    lxml: Default configuration of iterparse() and ETCompatXMLParser() allows XXE to local files

    lxml is a library for processing XML and HTML in the Python language. Prior to 6.1.0, using either of the two parsers in the default configuration (with resolve_entities=True) allows untrusted XML input to read local files. Setting the resolve_entities option explicitly to resolve_entities='internal' or resolve_entities=False disables the local file access. This vulnerability is fixed in 6.1.0.

    • Update to 4.2.1-1ubuntu0.6+esm1
    Published Updated
  3. CVE-2022-2309

    Medium · CVSS 5.3EPSS 2.45%No fix published

    NULL Pointer Dereference in lxml/lxml

    NULL Pointer Dereference allows attackers to cause a denial of service (or application crash). This only applies when lxml is used together with libxml2 2.9.10 through 2.9.14. libxml2 2.9.9 and earlier are not affected. It allows triggering crashes through forged input data, given a vulnerable code sequence in the application. The vulnerability is caused by the iterwalk function (also used by the canonicalize function). Such code shouldn't be in wide-spread use, given that parsing + iterwalk would usually be replaced with the more efficient iterparse function. However, an XML converter that serialises to C14N would also be vulnerable, for exa

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →