p PatchFirst

PatchFirst · Latest vulnerabilities

php-phpseclib vulnerabilities

Vulnerabilities published for php-phpseclib in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2026-84308

    Medium · CVSS 6.3EPSS 0.33%No fix published

    phpseclib — non-constant-time X25519 scalar multiplication permits full private-key recovery

    phpseclib is a PHP secure communications library. Prior to 3.0.57 and 4.0.1, pure-PHP X25519 scalar multiplication in phpseclib/Math/PrimeField/Integer.php performs data-dependent conditional modular reductions in add() and subtract(). During the Montgomery ladder in phpseclib/Crypt/EC/BaseCurves/Montgomery.php, the reduction behavior of each step depends on the secret scalar prefix, creating per-step timing and libgmp call-count observations that can reveal a reused 251-bit clamped private scalar. The phpseclib/Crypt/EC/Formats/Keys/MontgomeryPrivate.php derivation path invokes the pure-PHP multiplication without a native-engine check, while

    Published Updated
  2. CVE-2026-44167

    High · CVSS 7.5EPSS 0.2%Fix available

    phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

    phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

    • Update to 2.0.9-1ubuntu0.1~esm3
    Published Updated
  3. CVE-2026-40194

    Low · CVSS 3.7EPSS 0.36%Fix available

    phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals()

    phpseclib is a PHP secure communications library. Starting in 0.1.1 and prior to 3.0.51, 2.0.53, and 1.0.28, phpseclib\Net\SSH2::get_binary_packet() uses PHP's != operator to compare a received SSH packet HMAC against the locally computed HMAC. != on equal-length binary strings in PHP uses memcmp(), which short-circuits on the first differing byte. This is a real variable-time comparison (CWE-208), proven by scaling benchmarks. This vulnerability is fixed in 3.0.51, 2.0.53, and 1.0.28.

    • Update to 2.0.9-1ubuntu0.1~esm3
    Published Updated
  4. CVE-2026-32935

    High · CVSS 8.2EPSS 0.39%Fix available

    phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

    phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.

    • Update to 2.0.9-1ubuntu0.1~esm3
    Published Updated
  5. CVE-2023-52892

    High · CVSS 7.5EPSS 0.38%Fix available

    CVE-2023-52892

    In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in Subject Alternative Name fields in TLS certificates are incorrectly allowed to have a special meaning in regular expressions (such as a + wildcard), leading to name confusion in X.509 certificate host verification.

    • Update to 2.0.9-1ubuntu0.1~esm2
    Published Updated
  6. CVE-2024-27354

    High · CVSS 7.5EPSS 0.6%Fix available

    CVE-2024-27354

    An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.

    • Update to 2.0.9-1ubuntu0.1~esm2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →