p PatchFirst

PatchFirst · Latest vulnerabilities

sofia-sip vulnerabilities

Vulnerability published for sofia-sip in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-110658

    Medium · CVSS 6.9EPSS 0.67%No fix published

    Sofia-SIP through 1.13.18 Heap Out-of-Bounds Read via msg_multipart_parse

    Sofia-SIP through 1.13.18 contains a heap out-of-bounds read vulnerability in msg_multipart_parse() that allows unauthenticated remote attackers to crash the process by sending oversized MIME boundaries. Attackers can send an INVITE with a multipart Content-Type whose boundary exceeds the body length, causing memcmp to read past the heap buffer and crash the process.

    Published Updated
  2. CVE-2023-32307

    High · CVSS 7.5EPSS 1.06%Fix available

    heap-over-flow and integer-overflow in sofia-sip

    Sofia-SIP is an open-source SIP User-Agent library, compliant with the IETF RFC3261 specification. Referring to [GHSA-8599-x7rq-fr54](https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-8599-x7rq-fr54), several other potential heap-over-flow and integer-overflow in stun_parse_attr_error_code and stun_parse_attr_uint32 were found because the lack of attributes length check when Sofia-SIP handles STUN packets. The previous patch of [GHSA-8599-x7rq-fr54](https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-8599-x7rq-fr54) fixed the vulnerability when attr_type did not match the enum value, but there are also vulnerabilit

    • Update to 1.12.11+20110422.1-2.1+deb10u3ubuntu0.18.04.1~esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →