p PatchFirst

PatchFirst · Latest vulnerabilities

catdoc vulnerabilities

Vulnerabilities published for catdoc in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 12

  1. CVE-2026-111127

    Medium · CVSS 6.9EPSS 0.13%No fix published

    catdoc through 0.95 Out-of-Bounds Read via xls2csv copy_unicode_string

    catdoc through 0.95 contains an out-of-bounds read vulnerability in copy_unicode_string() in src/xlsparse.c that allows attackers to read past buffers via an unchecked string character count. Attackers can supply a crafted .xls file declaring 0xFFFF two-byte characters in LABEL, STRING, or SST records to disclose adjacent memory through xls2csv output or crash the process.

    Published Updated
  2. CVE-2026-111126

    Medium · CVSS 6.9EPSS 0.2%No fix published

    catdoc through 0.95 Out-of-Bounds Read in xls2csv MULRK Record Handler

    catdoc through 0.95 contains an out-of-bounds read vulnerability in the MULRK record handler of process_item() in src/xlsparse.c that allows attackers to read past the static rec buffer via a crafted end column. Attackers can supply a crafted .xls workbook or BIFF stream with a large endcol to xls2csv to disclose adjacent process memory as CSV cells or crash the process.

    Published Updated
  3. CVE-2024-48877

    High · CVSS 8.4EPSS 0.33%Fix available

    CVE-2024-48877

    A memory corruption vulnerability exists in the Shared String Table Record Parser implementation in xls2csv utility version 0.95. A specially crafted malformed file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

    • Update to 1:0.95-4.1ubuntu0.20.04.1~esm1
    Published Updated
  4. CVE-2024-52035

    High · CVSS 8.4EPSS 0.31%Fix available

    CVE-2024-52035

    An integer overflow vulnerability exists in the OLE Document File Allocation Table Parser functionality of catdoc 0.95. A specially crafted malformed file can lead to heap-based memory corruption. An attacker can provide a malicious file to trigger this vulnerability.

    • Update to 1:0.95-4.1ubuntu0.20.04.1~esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →