p PatchFirst

PatchFirst · Latest vulnerabilities

libphp-phpmailer vulnerabilities

Vulnerabilities published for libphp-phpmailer in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1

  1. CVE-2021-3603

    High · CVSS 8.1EPSS 2.26%Fix available

    Inclusion of Functionality from Untrusted Control Sphere in PHPMailer/PHPMailer

    PHPMailer 6.4.1 and earlier contain a vulnerability that can result in untrusted code being called (if such code is injected into the host project's scope by other means). If the $patternselect parameter to validateAddress() is set to 'php' (the default, defined by PHPMailer::$validator), and the global namespace contains a function called php, it will be called in preference to the built-in validator of the same name. Mitigated in PHPMailer 6.5.0 by denying the use of simple strings as validator function names.

    • Update to 6.2.0-2ubuntu0.1~esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →