p PatchFirst

PatchFirst · Latest vulnerabilities

phpseclib vulnerabilities

Vulnerabilities published for phpseclib in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2023-52892

    High · CVSS 7.5EPSS 0.38%Fix available

    CVE-2023-52892

    In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in Subject Alternative Name fields in TLS certificates are incorrectly allowed to have a special meaning in regular expressions (such as a + wildcard), leading to name confusion in X.509 certificate host verification.

    • Update to 1.0.20-1ubuntu0.1~esm1
    Published Updated
  2. CVE-2024-27354

    High · CVSS 7.5EPSS 0.6%Fix available

    CVE-2024-27354

    An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.

    • Update to 1.0.20-1ubuntu0.1~esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →