p PatchFirst

PatchFirst · Latest vulnerabilities

vlc vulnerabilities

Vulnerability published for vlc in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2026-102875

    High · CVSS 8.5EPSS 0.17%No fix published

    VLC media player before 3.0.24 Path Traversal via skins2

    VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

    Published Updated
  2. CVE-2026-73324

    Medium · CVSS 5.3EPSS 0.24%No fix published

    VLC media player 3.0.0 through 3.0.23 information disclosure vulnerability

    Certain VLC media player builds in versions 3.0.0 through 3.0.23 contain a memory-safety vulnerability reachable when processing media from an attacker-controlled network source. Exploitation requires user interaction and may disclose a limited, layout-dependent amount of VLC process memory. Exposure depends on build configuration.

    Published Updated
  3. CVE-2026-56711

    High · CVSS 7.3EPSS 0.12%No fix published

    VLC media player 3.0.0 through 3.0.23 memory corruption vulnerability

    VLC media player versions 3.0.0 through 3.0.23 contain a memory-safety vulnerability reachable when processing crafted media. Exploitation requires user interaction and may result in application termination or code execution with the privileges of the VLC process.

    Published Updated
  4. CVE-2024-46461

    High · CVSS 8EPSS 0.6%Fix available

    CVE-2024-46461

    VLC media player 3.0.20 and earlier is vulnerable to denial of service through an integer overflow which could be triggered with a maliciously crafted mms stream (heap based overflow). If successful, a malicious third party could trigger either a crash of VLC or an arbitrary code execution with the target user's privileges.

    • Update to 3.0.16-1ubuntu0.1~esm3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →