USN-2214-2
USN-2214-2 · libxml2 regression
This page contains facts from public vulnerability sources. Check the original advisory before updating.
USN-2214-1 fixed vulnerabilities in libxml2. The upstream fix introduced a regression when using xmllint with the --postvalid option. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Daniel Berrange discovered that libxml2 would incorrectly perform entity substitution even when requested not to. If a user or automated system were tricked into opening a specially crafted document, an attacker could possibly cause resource consumption, resulting in a denial of service.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libxml2 Ubuntu:14.04:LTS
- Versions
- 2.9.1+dfsg1-3ubuntu2
- 2.9.1+dfsg1-3ubuntu3
- 2.9.1+dfsg1-3ubuntu4
- 2.9.1+dfsg1-3ubuntu4.1
- Affected ranges
- ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.2
Update to 2.9.1+dfsg1-3ubuntu4.2